summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlec Mev2020-05-05 18:34:08 +0100
committerAlec Mev2020-05-05 18:34:08 +0100
commit70604d931c09f637f51c06ff7248daf2f04e1cd5 (patch)
tree6939de8ace18bd550b1a33c1a4484c88a7d114e8
downloadaur-70604d931c09f637f51c06ff7248daf2f04e1cd5.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11c48ed9b1fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = zsh-theme-minimal
+ pkgdesc = A minimal and extensible Zsh theme
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/subnixr/minimal
+ arch = any
+ license = GPL3
+ depends = zsh
+ optdepends = git: Git branch status support
+ optdepends = hg: Mercurial branch status support
+ source = zsh-theme-minimal-1.0.4.tar.gz::https://github.com/subnixr/minimal/archive/1.0.4.tar.gz
+ sha256sums = 910e109b366e4c334a6d0fc6021dc3810a4a7877bd985526dd63c5a12c00daf1
+
+pkgname = zsh-theme-minimal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..66745a53564c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar
+/*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27647ad2e36b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alec Mev <alec@mev.earth>
+
+_name=minimal
+pkgname="zsh-theme-${_name}"
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='A minimal and extensible Zsh theme'
+arch=('any')
+url=https://github.com/subnixr/minimal
+license=('GPL3')
+depends=('zsh')
+optdepends=(
+ 'git: Git branch status support'
+ 'hg: Mercurial branch status support'
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/subnixr/minimal/archive/${pkgver}.tar.gz")
+sha256sums=('910e109b366e4c334a6d0fc6021dc3810a4a7877bd985526dd63c5a12c00daf1')
+
+package() {
+ cd "minimal-${pkgver}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ install -Dm644 -t "${pkgdir}/usr/share/zsh/plugins/theme-${_name}" minimal.zsh
+}