summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Dejonckheere2016-03-16 23:18:20 +0100
committerFlorian Dejonckheere2016-03-16 23:18:20 +0100
commit7ea9c2b83b9ae9ad53602bec9641126b8661a29b (patch)
tree9327faea003f188f5bf2dce02d7329060c07e7a2
downloadaur-7ea9c2b83b9ae9ad53602bec9641126b8661a29b.tar.gz
Remove oh-my-zsh dependency
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--zsh-theme-powerlevel9k.install11
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68c5e6bb77ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Mar 16 22:07:56 UTC 2016
+pkgbase = zsh-theme-powerlevel9k-git
+ pkgdesc = Powerlevel9k theme for zsh
+ pkgver = v0.3.1.r10.g2630526
+ pkgrel = 2
+ url = https://github.com/bhilburn/powerlevel9k
+ install = zsh-theme-powerlevel9k.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = zsh
+ optdepends = oh-my-zsh-git: oh-my-zsh integration
+ optdepends = prezto-git: Prezto integration
+ optdepends = antigen-git: Antigen integration
+ optdepends = zpm: ZPM integration
+ optdepends = zsh-zim-git: Zim integration
+ provides = zsh-theme-powerlevel9k
+ conflicts = zsh-theme-powerlevel9k
+ source = powerlevel9k::git+https://github.com/bhilburn/powerlevel9k.git
+ sha256sums = SKIP
+
+pkgname = zsh-theme-powerlevel9k-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b7a0bc77fd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Florian Dejonckheere <florian at floriandejonckheere dot be>
+# Contributor: jyantis <yantis@yantis.net>
+
+_pkgname=powerlevel9k
+pkgname=zsh-theme-${_pkgname}-git
+pkgver=v0.3.1.r10.g2630526
+pkgrel=2
+pkgdesc='Powerlevel9k theme for zsh'
+arch=('any')
+url='https://github.com/bhilburn/powerlevel9k'
+license=('custom')
+depends=('zsh')
+optdepends=('oh-my-zsh-git: oh-my-zsh integration'
+ 'prezto-git: Prezto integration'
+ 'antigen-git: Antigen integration'
+ 'zpm: ZPM integration'
+ 'zsh-zim-git: Zim integration')
+source=("${_pkgname}::git+https://github.com/bhilburn/${_pkgname}.git")
+sha256sums=('SKIP')
+makedepends=('git')
+provides=("zsh-theme-${_pkgname}")
+conflicts=("zsh-theme-${_pkgname}")
+install="zsh-theme-${_pkgname}.install"
+
+pkgver()
+{
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}"
+
+ # No license
+ # Install Readme as License in case in the future some type of license is added
+ install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # Install the theme
+ install -D -m644 powerlevel9k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
+
+ # Install the utilities
+ for FILE in functions/*.zsh; do
+ install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
+ done
+}
diff --git a/zsh-theme-powerlevel9k.install b/zsh-theme-powerlevel9k.install
new file mode 100644
index 000000000000..aefbbff76b45
--- /dev/null
+++ b/zsh-theme-powerlevel9k.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo "Usage:"
+ echo "Configure your setup to use the theme. Instructions for different frameworks can be found at"
+ echo "https://github.com/bhilburn/powerlevel9k/wiki/Install-Instructions"
+ echo
+ echo "Requirements"
+ echo "Vim Powerline patched font. Many different ones on the AUR"
+ echo "Make sure terminal is using 256-colors mode with export TERM=\"xterm-256color\"."
+ echo
+}