summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2018-04-01 19:51:00 -0600
committerSumner Evans2018-04-01 19:51:00 -0600
commit6812710a8aa1ab97a55fc7cb32caec76c436ce21 (patch)
tree9e88abe19f2964b0bfe8cf3b6999c7560ba7870a
downloadaur-6812710a8aa1ab97a55fc7cb32caec76c436ce21.tar.gz
Initial Commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore20
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD28
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5d15720fcaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = zsh-you-should-use
+ pkgdesc = ZSH plugin that reminds you to use existing aliases for commands you just typed
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/MichaelAquilina/zsh-you-should-use
+ arch = any
+ license = MIT
+ source = https://github.com/MichaelAquilina/zsh-you-should-use/archive/0.4.1.tar.gz
+ sha256sums = 7af71b463d998fa2388a4dd52ea75ce9ee1568cf233c8b2e41b690b04e250b40
+
+pkgname = zsh-you-should-use
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f97a6eff873
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..cd3176fb3e1c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,2 @@
+all:
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f97fbda85ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonathan Sumner Evans <sumner.evans98@gmail.com>
+
+pkgname="zsh-you-should-use"
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="ZSH plugin that reminds you to use existing aliases for commands you just typed"
+url="https://github.com/MichaelAquilina/zsh-you-should-use"
+arch=("any")
+license=("MIT")
+source=("https://github.com/MichaelAquilina/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("7af71b463d998fa2388a4dd52ea75ce9ee1568cf233c8b2e41b690b04e250b40")
+
+package() {
+ install -d "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/you-should-use.plugin.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+
+ # License
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+post_install() {
+ cat << EOF
+To activate zsh-you-should-use add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/zsh-you-should-use/you-should-use.plugin.zsh
+EOF
+}