summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Jürgens2022-04-26 13:58:26 +0000
committerMalte Jürgens2022-04-26 13:58:26 +0000
commit7cb59a111f41a8c9896479e9ef331c727cb2b9d7 (patch)
treebdd672cba37491a728282c9c6e16a2eef5ca6f46
parent8e82024cdb1fde8e2dd8a7bfbe0c2450759b89c2 (diff)
downloadaur-7cb59a111f41a8c9896479e9ef331c727cb2b9d7.tar.gz
fix patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--zspotify-paths.patch11
3 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96cd8c29e878..8b43e8d0e74f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zspotify
pkgdesc = A Spotify downloader needing only a python interpreter and ffmpeg.
pkgver = 0.5.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/afkcodes/zspotify
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 34185d8f5df3..f98b83928fed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zspotify
pkgver=0.5.2
-pkgrel=2
+pkgrel=3
pkgdesc="A Spotify downloader needing only a python interpreter and ffmpeg."
arch=("x86_64")
url="https://github.com/afkcodes/zspotify"
diff --git a/zspotify-paths.patch b/zspotify-paths.patch
index c23786565622..57408c8ce1bb 100644
--- a/zspotify-paths.patch
+++ b/zspotify-paths.patch
@@ -95,6 +95,17 @@
@classmethod
def get_all_genres(cls) -> bool:
+--- a/zspotify/track.py
++++ b/zspotify/track.py
+@@ -199,7 +199,7 @@ def download_track(mode: str, track_id: str, extra_keys=None, disable_progressba
+ unit_divisor=1024,
+ disable=disable_progressbar
+ ) as p_bar:
+- for _ in range(int(total_size / ZSpotify.CONFIG.get_chunk_size()) + 1):
++ while stream.input_stream.stream().available() != 0:
+ data = stream.input_stream.stream().read(ZSpotify.CONFIG.get_chunk_size())
+ p_bar.update(file.write(data))
+ downloaded += len(data)
--- a/zspotify/zspotify.py
+++ b/zspotify/zspotify.py
@@ -28,7 +28,9 @@ class ZSpotify: