summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-04-17 09:56:23 -0400
committerGuillaume Horel2019-04-17 09:56:23 -0400
commit476b0f35318d6757d5217ae1f7761f47013256ac (patch)
treeeb03ee0f7f1f867192cd491df3dba7634b25e50c
parent092d2fd6cffb62b03bb8b5323a5e08c06389ccfd (diff)
downloadaur-476b0f35318d6757d5217ae1f7761f47013256ac.tar.gz
version bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3964778dfe70..b93a90dd125b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = zstd-static
pkgdesc = Zstandard - Fast real-time compression algorithm
- pkgver = 1.3.8
+ pkgver = 1.4.0
pkgrel = 1
url = http://www.zstd.net/
arch = x86_64
license = BSD
- makedepends = gtest
depends = zlib
depends = xz
depends = lz4
provides = zstd
conflicts = zstd
options = staticlibs
- source = https://github.com/facebook/zstd/archive/v1.3.8.tar.gz
- sha256sums = 90d902a1282cc4e197a8023b6d6e8d331c1fd1dfe60f7f8e4ee9da40da886dc3
+ source = https://github.com/facebook/zstd/archive/v1.4.0.tar.gz
+ sha256sums = 63be339137d2b683c6d19a9e34f4fb684790e864fee13c7dd40e197a64c705c1
pkgname = zstd-static
diff --git a/PKGBUILD b/PKGBUILD
index c85b0a809df9..f1ea477ed118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,16 @@
pkgname=zstd-static
_pkgname=${pkgname%-static}
-pkgver=1.3.8
+pkgver=1.4.0
pkgrel=1
pkgdesc='Zstandard - Fast real-time compression algorithm'
arch=('x86_64')
url='http://www.zstd.net/'
license=('BSD')
depends=('zlib' 'xz' 'lz4')
-makedepends=('gtest')
options=('staticlibs')
source=("https://github.com/facebook/zstd/archive/v${pkgver}.tar.gz")
-sha256sums=('90d902a1282cc4e197a8023b6d6e8d331c1fd1dfe60f7f8e4ee9da40da886dc3')
+sha256sums=('63be339137d2b683c6d19a9e34f4fb684790e864fee13c7dd40e197a64c705c1')
provides=('zstd')
conflicts=('zstd')
@@ -32,3 +31,8 @@ package() {
install -D -m755 contrib/pzstd/pzstd "$pkgdir/usr/bin/pzstd"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make check
+}