summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-03-04 17:33:39 +0000
committerJonathon Fernyhough2021-03-04 17:33:39 +0000
commit326254d241e52296551fabff77e4366d5485fe19 (patch)
treeb99bc10b163ec9c61cfecafeace3dc07c14c84b8
parent526188453c95beb918a9d40a517c38162b9895da (diff)
downloadaur-326254d241e52296551fabff77e4366d5485fe19.tar.gz
Update submodule handling
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02522f383d15..ea434ea31842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,12 @@ pkgbase = zsync2-git
makedepends = zlib
depends = curl
source = git+https://github.com/AppImage/zsync2.git
+ source = git+https://github.com/Taywee/args.git
+ source = git+https://github.com/AppImage/cpr.git
+ source = git+https://github.com/google/googletest.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
pkgname = zsync2-git
diff --git a/PKGBUILD b/PKGBUILD
index 70ee210b7966..f30fa89ef972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,14 @@ url="https://github.com/AppImage/zsync2"
license=("custom:Artistic")
depends=(curl)
makedepends=(cmake git gnutls openssl zlib)
-source=(git+$url.git)
-b2sums=('SKIP')
+source=(git+$url.git
+ git+https://github.com/Taywee/args.git
+ git+https://github.com/AppImage/cpr.git
+ git+https://github.com/google/googletest.git)
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd ${pkgname/-git/}
@@ -22,7 +28,11 @@ pkgver() {
prepare() {
cd ${pkgname/-git/}
- git submodule update --init
+ git submodule init
+ git config submodule.lib/args.url "$srcdir"/args
+ git config submodule.lib/cpr.url "$srcdir"/cpr
+ git config submodule.lib/gtest.url "$srcdir"/googletest
+ git submodule update
}
build() {