summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-03-05 02:21:18 +0000
committerJonathon Fernyhough2021-03-05 02:21:18 +0000
commit96bc13029f8c44f44206abeb62401526c0b48cd6 (patch)
treeb99bc10b163ec9c61cfecafeace3dc07c14c84b8
parent92c24590a86d17347eae91fd09bea9b92a3e7eca (diff)
downloadaur-96bc13029f8c44f44206abeb62401526c0b48cd6.tar.gz
Merged https://github.com/AppImage/zsync2/pull/57
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--http2.patch13
3 files changed, 3 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42a2395a420d..ea434ea31842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsync2-git
pkgdesc = A file transfer program that's able to connect to rsync servers
pkgver = 2.0.0pre
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/AppImage/zsync2
arch = x86_64
license = custom:Artistic
@@ -15,12 +15,10 @@ pkgbase = zsync2-git
source = git+https://github.com/Taywee/args.git
source = git+https://github.com/AppImage/cpr.git
source = git+https://github.com/google/googletest.git
- source = http2.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = 2306c159a0575442902efdf7304a989709baf2206cf87bfd9865595679f2d42e135c40513f651c6e15e9f30a87f1983ab6b2bf172b5090dc62af0f03ab198cb3
pkgname = zsync2-git
diff --git a/PKGBUILD b/PKGBUILD
index fe4487a81326..f30fa89ef972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,11 @@ makedepends=(cmake git gnutls openssl zlib)
source=(git+$url.git
git+https://github.com/Taywee/args.git
git+https://github.com/AppImage/cpr.git
- git+https://github.com/google/googletest.git
- http2.patch)
+ git+https://github.com/google/googletest.git)
b2sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '2306c159a0575442902efdf7304a989709baf2206cf87bfd9865595679f2d42e135c40513f651c6e15e9f30a87f1983ab6b2bf172b5090dc62af0f03ab198cb3')
+ 'SKIP')
pkgver() {
cd ${pkgname/-git/}
@@ -35,9 +33,6 @@ prepare() {
git config submodule.lib/cpr.url "$srcdir"/cpr
git config submodule.lib/gtest.url "$srcdir"/googletest
git submodule update
-
- # https://github.com/AppImage/zsync2/pull/57
- git apply "$srcdir"/http2.patch
}
build() {
diff --git a/http2.patch b/http2.patch
deleted file mode 100644
index f40f3ead6c5e..000000000000
--- a/http2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/legacy_http.c b/src/legacy_http.c
-index f97c5a2..03e2919 100644
---- a/src/legacy_http.c
-+++ b/src/legacy_http.c
-@@ -521,7 +521,7 @@ int range_fetch_read_http_headers(struct range_fetch *rf) {
- }
- if (buf[0] == 0)
- return 0; /* EOF, caller decides if that's an error */
-- if (memcmp(buf, "HTTP/1", 6) != 0 || (p = strchr(buf, ' ')) == NULL) {
-+ if (memcmp(buf, "HTTP/", 5) != 0 || (p = strchr(buf, ' ')) == NULL) {
- log_message("got non-HTTP response '%s'\n", buf);
- return -1;
- }