summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-04-08 21:53:42 +0100
committerJonathon Fernyhough2021-04-08 21:53:42 +0100
commit9e75e613690d94b00c4370d5bf90cda38e11b674 (patch)
treed1976849c7c035d4d4596aad7a7531afa5390ab1
parent75a37f7eab5c432e3daca3a3aaed9cd65b3bf39e (diff)
downloadaur-9e75e613690d94b00c4370d5bf90cda38e11b674.tar.gz
Revert
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--size-t.patch51
3 files changed, 6 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8091b176d5c1..8a0dfb23cd44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zsync2-git
pkgdesc = A file transfer program that's able to connect to rsync servers
- pkgver = 2.0.0r175.a8e2d68
- pkgrel = 2
+ pkgver = 2.0.0pre
+ pkgrel = 1
url = https://github.com/AppImage/zsync2
arch = x86_64
license = custom:Artistic
@@ -17,12 +17,10 @@ pkgbase = zsync2-git
source = git+https://github.com/Taywee/args.git
source = git+https://github.com/AppImage/cpr.git
source = git+https://github.com/google/googletest.git
- source = size-t.patch
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = c5db4f79767f554e2b90455edfa55aa0eefa11df4eabd333809903ccd76d882c73ff043add6da14dbd02672ac50fc6d634d384b99ace468bf8a9a53dc1870cbf
pkgname = zsync2-git
diff --git a/PKGBUILD b/PKGBUILD
index aab7253746f6..201e6561521f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonathon Fernyhough <jonathon+m2x+dev>
pkgname=zsync2-git
-pkgver=2.0.0r175.a8e2d68
-pkgrel=2
+pkgver=2.0.0pre
+pkgrel=1
pkgdesc="A file transfer program that's able to connect to rsync servers"
arch=(x86_64)
url="https://github.com/AppImage/zsync2"
@@ -14,13 +14,11 @@ makedepends=(cmake git gnutls openssl zlib)
source=(git+$url.git
git+https://github.com/Taywee/args.git
git+https://github.com/AppImage/cpr.git
- git+https://github.com/google/googletest.git
- size-t.patch)
+ git+https://github.com/google/googletest.git)
b2sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'c5db4f79767f554e2b90455edfa55aa0eefa11df4eabd333809903ccd76d882c73ff043add6da14dbd02672ac50fc6d634d384b99ace468bf8a9a53dc1870cbf')
+ 'SKIP')
pkgver() {
cd ${pkgname/-git/}
@@ -37,8 +35,6 @@ prepare() {
git config submodule.lib/cpr.url "$srcdir"/cpr
git config submodule.lib/gtest.url "$srcdir"/googletest
git submodule update
-
- git apply ../size-t.patch
}
build() {
diff --git a/size-t.patch b/size-t.patch
deleted file mode 100644
index 04ac8a2d6b69..000000000000
--- a/size-t.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/src/legacy_http.c b/src/legacy_http.c
-index 7c67a84..5b947c4 100644
---- a/src/legacy_http.c
-+++ b/src/legacy_http.c
-@@ -74,8 +74,8 @@ struct http_file
- } handle;
-
- char *buffer;
-- uint64_t buffer_len;
-- uint64_t buffer_pos;
-+ size_t buffer_len;
-+ size_t buffer_pos;
- int still_running;
- };
-
-@@ -340,7 +340,7 @@ static int fill_buffer(HTTP_FILE *file, size_t want, CURLM* multi_handle)
- *
- * Removes `want` bytes from the front of the buffer.
- */
--static int use_buffer(HTTP_FILE *file, uint64_t want)
-+static int use_buffer(HTTP_FILE *file, size_t want)
- {
- if(file->buffer_pos <= want){
- /* trash the buffer */
-@@ -509,7 +509,7 @@ static void buflwr(char *s) {
- int range_fetch_read_http_headers(struct range_fetch *rf) {
- char buf[512];
- int status;
-- uint64_t seen_location = 0;
-+ size_t seen_location = 0;
-
- { /* read status line */
- char *p;
-@@ -571,7 +571,7 @@ int range_fetch_read_http_headers(struct range_fetch *rf) {
- p += 2;
- buflwr(buf);
- { /* Remove the trailing \r\n from the value */
-- int len = strcspn(p, "\r\n");
-+ size_t len = strcspn(p, "\r\n");
- p[len] = 0;
- }
- /* buf is the header name (lower-cased), p the value */
-@@ -580,7 +580,7 @@ int range_fetch_read_http_headers(struct range_fetch *rf) {
- if (status == 206 && !strcmp(buf, "content-range")) {
- /* Okay, we're getting a non-MIME block from the remote. Get the
- * range and set our state appropriately */
-- uint64_t from, to;
-+ size_t from, to;
- sscanf(p, "bytes " OFF_T_PF "-" OFF_T_PF "/", &from, &to);
- if (from <= to) {
- rf->block_left = to + 1 - from;