summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2015-07-28 11:26:15 +0300
committerAdrian Perez de Castro2015-07-28 11:26:15 +0300
commit082bfa1b13e0c9692b26185b2c3802a43cbd67a2 (patch)
tree9d485367e2938f1f28c6ef1660570d295ef8fd4b
downloadaur-082bfa1b13e0c9692b26185b2c3802a43cbd67a2.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--firefox-theme.install17
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6175b9e0047
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zuki-themes-git
+ pkgdesc = A selection of themes for GTK3, gnome-shell and more.
+ pkgver = r53.0b8043c
+ pkgrel = 1
+ url = https://github.com/lassekongo83/zuki-themes
+ install = firefox-theme.install
+ arch = any
+ license = GPL3
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ optdepends = gnome-themes-standard: Required for the GTK3 theme
+ optdepends = ttf-droid: Font family for the Gnome Shell theme
+ conflicts = zukitwo-themes
+ source = zuki-themes-git::git+https://github.com/leigh123linux/zuki-themes#branch=gtk-316
+ sha512sums = SKIP
+
+pkgname = zuki-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba332bf770dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+# Contributor: martinjlowm <martin {at} martinjlowm {dot} dk>
+
+pkgname=zuki-themes-git
+pkgver=r53.0b8043c
+pkgrel=1
+pkgdesc="A selection of themes for GTK3, gnome-shell and more."
+arch=('any')
+url="https://github.com/lassekongo83/zuki-themes"
+license=('GPL3')
+depends=('gtk-engine-murrine' 'gtk-engines')
+conflicts=('zukitwo-themes')
+optdepends=('gnome-themes-standard: Required for the GTK3 theme'
+ 'ttf-droid: Font family for the Gnome Shell theme')
+install='firefox-theme.install'
+
+# TODO: Revert to the upstream repository when/if the GTK+ 3.16 branch is merged
+# source=("${pkgname}::git+${url}")
+source=("${pkgname}::git+https://github.com/leigh123linux/zuki-themes#branch=gtk-316")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ find */ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+}
diff --git a/firefox-theme.install b/firefox-theme.install
new file mode 100644
index 000000000000..3273271602f0
--- /dev/null
+++ b/firefox-theme.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo ""
+ echo "To update/enable the Firefox theme, run:"
+ echo " cp -R /usr/share/themes/Zukitre-firefox-theme/chrome ~/.mozilla/firefox/<profile_id>.default/"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo ""
+ echo "Remember to remove the Firefox theme if you've enabled it:"
+ echo " rm ~/.mozilla/firefox/<profile_id>.default/chrome/userChrome.css"
+ echo ""
+} \ No newline at end of file