summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-14 19:12:06 -0400
committerJean Lucas2019-08-14 19:27:47 -0400
commit3ce9951a2e1126ddfe35400b1fe20549a738751d (patch)
treef7a46500758c3c0fc84dbdb7b525aa074f043d37
parent554deb2c17440e061785435eddbed9e643b09e97 (diff)
downloadaur-3ce9951a2e1126ddfe35400b1fe20549a738751d.tar.gz
Update deps, source naming schema; fix build
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD20
-rw-r--r--zulip.desktop1
3 files changed, 16 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d25e99c610f..bc0ffccc185c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,22 @@
pkgbase = zulip-desktop
pkgdesc = Real-time team chat based on the email threading model
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://zulipchat.com
arch = i686
arch = x86_64
license = Apache
makedepends = npm
makedepends = python2
- makedepends = libxkbfile
- depends = alsa-lib
- depends = atk
- depends = at-spi2-atk
- depends = cairo
- depends = dbus
- depends = fontconfig
- depends = gdk-pixbuf2
- depends = glib2
+ makedepends = typescript
+ depends = libxkbfile
depends = gtk3
- depends = hicolor-icon-theme
- depends = libcups
- depends = libxcomposite
- depends = libxcursor
- depends = libxdamage
- depends = libxfixes
- depends = libxi
- depends = libxrandr
- depends = libxrender
depends = libxss
- depends = libxtst
- depends = nspr
depends = nss
- depends = pango
- source = https://github.com/zulip/zulip-desktop/archive/v4.0.0.tar.gz
+ source = zulip-desktop-4.0.0.tar.gz::https://github.com/zulip/zulip-desktop/archive/v4.0.0.tar.gz
source = zulip.desktop
sha512sums = 4cbdbc73d09ac50599cba460eccd0b72c901b68a00d4995b9bc16f0f980715155cafc1f14a5d1ab5a97672c5413679ce96f38212f7e0935df85b1c0f1e3465ec
- sha512sums = 396b3a3df1ca9fa61d2283eca60c71549e0db76e82b49afdd16c5d1d01fc42c18185555cd5e247e1a039ee998c5a1fd6b73886a67a10bdbadb54132769a58fa5
+ sha512sums = 7696a6874d17957f99452452723ae1a6b32b6814b018361a71ed1fe0191e1c6da6f3ad693e2e279615e74f687c380ff2f6dab8b69fcd82476e8f33b56a6b4cb5
pkgname = zulip-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 38f22eb97c0e..d153a7fc5f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Maintainer: Jean Lucas <jean@4ray.co>
# Contributor: kaptoxic <kaptoxic at yahoo dot com>
# Contributor: Matthew Avant <matthew dot avant at gmail dot com>
# Contributor: Rose Ames <rose at happyspork dot com>
-# Contributor: Jean Lucas <jean@4ray.co>
pkgname=zulip-desktop
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Real-time team chat based on the email threading model'
arch=(i686 x86_64)
url=https://zulipchat.com
license=(Apache)
-depends=(alsa-lib atk at-spi2-atk cairo dbus fontconfig gdk-pixbuf2 glib2 gtk3 hicolor-icon-theme libcups libxcomposite libxcursor libxdamage libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango)
-makedepends=(npm python2 libxkbfile)
-source=(https://github.com/zulip/$pkgname/archive/v$pkgver.tar.gz
+depends=(libxkbfile gtk3 libxss nss)
+makedepends=(npm python2 typescript)
+source=($pkgname-$pkgver.tar.gz::https://github.com/zulip/$pkgname/archive/v$pkgver.tar.gz
zulip.desktop)
sha512sums=('4cbdbc73d09ac50599cba460eccd0b72c901b68a00d4995b9bc16f0f980715155cafc1f14a5d1ab5a97672c5413679ce96f38212f7e0935df85b1c0f1e3465ec'
- '396b3a3df1ca9fa61d2283eca60c71549e0db76e82b49afdd16c5d1d01fc42c18185555cd5e247e1a039ee998c5a1fd6b73886a67a10bdbadb54132769a58fa5')
+ '7696a6874d17957f99452452723ae1a6b32b6814b018361a71ed1fe0191e1c6da6f3ad693e2e279615e74f687c380ff2f6dab8b69fcd82476e8f33b56a6b4cb5')
build() {
cd $pkgname-$pkgver
- npm install
+ npm i
+ npm run pack
}
package() {
- install -Dm 644 zulip.desktop -t "$pkgdir"/usr/share/applications
-
cd $pkgname-$pkgver
- install -dm 755 "$pkgdir"/usr/{lib,bin}
+ install -d "$pkgdir"/usr/{lib,bin}
cp -a dist/linux-unpacked "$pkgdir"/usr/lib/$pkgname
ln -s /usr/lib/$pkgname/zulip "$pkgdir"/usr/bin
+ install -Dm 644 ../zulip.desktop -t "$pkgdir"/usr/share/applications
for i in 16 24 32 48 64 96 128 256 512; do
install -Dm 644 build/icons/${i}x${i}.png \
"$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png
diff --git a/zulip.desktop b/zulip.desktop
index fb5f18bc784d..4768ad88eaf6 100644
--- a/zulip.desktop
+++ b/zulip.desktop
@@ -1,4 +1,5 @@
[Desktop Entry]
+Version=1.0
Type=Application
Name=Zulip
Comment=Real-time team chat based on the email threading model