summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraspen2021-01-05 00:36:19 -0500
committeraspen2021-01-05 00:37:20 -0500
commit6fa99de0bb9b22709e65ae228fa0b1f6624d9d64 (patch)
treef34bc27271537c069c9774d7c2bab94d7963b3f5
downloadaur-6fa99de0bb9b22709e65ae228fa0b1f6624d9d64.tar.gz
🎉 Make `-electron` version of Zulip
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--zulip-desktop.desktop9
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c26e084a6e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = zulip-desktop-electron
+ pkgdesc = Real-time team chat based on the email threading model, using system electron
+ pkgver = 5.5.0
+ pkgrel = 1
+ url = https://zulipchat.com
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = npm
+ makedepends = python2
+ depends = libxkbfile
+ depends = gtk3
+ depends = libxss
+ depends = nss
+ depends = electron
+ provides = zulip-desktop
+ conflicts = zulip-desktop
+ source = zulip-desktop-5.5.0.tar.gz::https://github.com/zulip/zulip-desktop/archive/v5.5.0.tar.gz
+ source = zulip-desktop.desktop
+ sha512sums = d3a73896b97b9e0353f168e3b5d98ef6d5f5dc8bdeb6314a832a8664f01b5aa62e802ff883647a7379b1671ce1bb0404256771ed3c84590d2fcf83349d62fa06
+ sha512sums = 51708745a8e8e09a5ac949c6f4814e86118008c07c3b03d84559468dcaef880431f401ab06bd552b32376d93831a14b6b9337c66dfe23531016266a155f22aa3
+
+pkgname = zulip-desktop-electron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eef8a3f43184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aspen <aspen@aspenuwu.me>
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Maintainer: AI5C <ai5c@ai5c.com>
+# Contributor: kaptoxic <kaptoxic at yahoo dot com>
+# Contributor: Matthew Avant <matthew dot avant at gmail dot com>
+# Contributor: Rose Ames <rose at happyspork dot com>
+
+_pkgbase=zulip-desktop
+pkgname=$_pkgbase-electron
+pkgver=5.5.0
+pkgrel=1
+pkgdesc='Real-time team chat based on the email threading model, using system electron'
+arch=(i686 x86_64)
+url=https://zulipchat.com
+license=(Apache)
+depends=(libxkbfile gtk3 libxss nss electron)
+makedepends=(npm python2)
+provides=($_pkgbase)
+conflicts=($_pkgbase)
+source=($_pkgbase-$pkgver.tar.gz::https://github.com/zulip/$_pkgbase/archive/v$pkgver.tar.gz
+ $_pkgbase.desktop)
+sha512sums=('d3a73896b97b9e0353f168e3b5d98ef6d5f5dc8bdeb6314a832a8664f01b5aa62e802ff883647a7379b1671ce1bb0404256771ed3c84590d2fcf83349d62fa06'
+ '51708745a8e8e09a5ac949c6f4814e86118008c07c3b03d84559468dcaef880431f401ab06bd552b32376d93831a14b6b9337c66dfe23531016266a155f22aa3')
+
+build() {
+ cd $_pkgbase-$pkgver
+ npm i
+ npm run pack
+}
+
+package() {
+ cd $_pkgbase-$pkgver
+
+ install -d "$pkgdir"/usr/{lib,bin}
+ cp -a dist/linux-unpacked "$pkgdir"/usr/lib/$_pkgbase
+ ln -s /usr/lib/$_pkgbase/zulip "$pkgdir"/usr/bin
+
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgbase
+
+ install -Dm 644 ../$_pkgbase.desktop -t "$pkgdir"/usr/share/applications
+ for i in 16 24 32 48 64 96 128 256 512; do
+ install -Dm 644 build/icons/${i}x${i}.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png
+ done
+}
diff --git a/zulip-desktop.desktop b/zulip-desktop.desktop
new file mode 100644
index 000000000000..a1397596e92f
--- /dev/null
+++ b/zulip-desktop.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Zulip
+Comment=Real-time team chat based on the email threading model
+Exec=electron /usr/lib/zulip-desktop/resources/app.asar
+Icon=zulip
+Categories=Network;InstantMessaging;
+Terminal=false \ No newline at end of file