summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-14 19:26:34 -0400
committerJean Lucas2019-08-14 19:26:40 -0400
commit61ad7b7057cfe3f65e8191389aba4001600136d9 (patch)
tree1b29cc676d9b9801e4340e32668e63658cdb83ac
parent389b59216af2c838d8f6d75c128cace63f3c86b4 (diff)
downloadaur-61ad7b7057cfe3f65e8191389aba4001600136d9.tar.gz
Update deps; Sentry bug no longer present
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD19
2 files changed, 8 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e74d0602f9f..25a392df3945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zulip-desktop-git
pkgdesc = Real-time team chat based on the email threading model (git)
- pkgver = 4.0.0+r1+gab62b8b
+ pkgver = 4.0.0+r2+gf8d93cf
pkgrel = 1
url = https://zulipchat.com
arch = i686
@@ -10,30 +10,10 @@ pkgbase = zulip-desktop-git
makedepends = npm
makedepends = python2
makedepends = typescript
- depends = alsa-lib
- depends = atk
- depends = at-spi2-atk
- depends = cairo
- depends = dbus
- depends = fontconfig
- depends = gdk-pixbuf2
- depends = glib2
- depends = gtk3
- depends = hicolor-icon-theme
- depends = libcups
- depends = libxcomposite
- depends = libxcursor
- depends = libxdamage
- depends = libxfixes
- depends = libxi
depends = libxkbfile
- depends = libxrandr
- depends = libxrender
+ depends = gtk3
depends = libxss
- depends = libxtst
- depends = nspr
depends = nss
- depends = pango
provides = zulip-desktop
conflicts = zulip-desktop
conflicts = zulip-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2a3a98e03e35..681e6c4d95d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Contributor: Jean Lucas <jean@4ray.co>
+# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=zulip-desktop-git
-pkgver=4.0.0+r1+gab62b8b
+pkgver=4.0.0+r2+gf8d93cf
pkgrel=1
pkgdesc='Real-time team chat based on the email threading model (git)'
arch=(i686 x86_64)
url=https://zulipchat.com
license=(Apache)
-depends=(alsa-lib atk at-spi2-atk cairo dbus fontconfig gdk-pixbuf2 glib2 gtk3 hicolor-icon-theme libcups libxcomposite libxcursor libxdamage libxfixes libxi libxkbfile libxrandr libxrender libxss libxtst nspr nss pango)
+depends=(libxkbfile gtk3 libxss nss)
makedepends=(git npm python2 typescript)
provides=(zulip-desktop)
conflicts=(zulip-desktop zulip-desktop-bin)
@@ -21,27 +21,20 @@ pkgver() {
git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
-prepare() {
- # We need an API key for Sentry, so let's not use it
- sed -i 's#!isDev#isDev#' ${pkgname/-git/}/app/renderer/js/utils/sentry-util.ts
-}
-
build() {
cd ${pkgname/-git/}
npm i
- tsc
- npx electron-builder --dir
+ npm run pack
}
package() {
- install -Dm 644 zulip.desktop -t "$pkgdir"/usr/share/applications
-
cd ${pkgname/-git/}
- mkdir "$pkgdir"/usr/{lib,bin}
+ install -d "$pkgdir"/usr/{lib,bin}
cp -a dist/linux-unpacked "$pkgdir"/usr/lib/${pkgname/-git/}
ln -s /usr/lib/${pkgname/-git/}/zulip "$pkgdir"/usr/bin
+ install -Dm 644 ../zulip.desktop -t "$pkgdir"/usr/share/applications
for i in 16 24 32 48 64 96 128 256 512; do
install -Dm 644 build/icons/${i}x${i}.png \
"$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png