summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-10-07 22:19:03 -0400
committerJean Lucas2019-10-07 22:19:03 -0400
commite585751fe9aab11cbb6dd14ec374644c0f2ae041 (patch)
tree685ce5c49c171b14e49536406765488b342ad719
parent61ad7b7057cfe3f65e8191389aba4001600136d9 (diff)
downloadaur-e585751fe9aab11cbb6dd14ec374644c0f2ae041.tar.gz
Remove typescript as makedep, update naming schemas
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
-rw-r--r--zulip-desktop.desktop (renamed from zulip.desktop)0
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25a392df3945..cf3e0ad0cf61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zulip-desktop-git
pkgdesc = Real-time team chat based on the email threading model (git)
- pkgver = 4.0.0+r2+gf8d93cf
+ pkgver = 4.0.0+r19+gdae7089
pkgrel = 1
url = https://zulipchat.com
arch = i686
@@ -9,16 +9,14 @@ pkgbase = zulip-desktop-git
makedepends = git
makedepends = npm
makedepends = python2
- makedepends = typescript
depends = libxkbfile
depends = gtk3
depends = libxss
depends = nss
provides = zulip-desktop
conflicts = zulip-desktop
- conflicts = zulip-desktop-bin
source = git+https://github.com/zulip/zulip-desktop
- source = zulip.desktop
+ source = zulip-desktop.desktop
sha512sums = SKIP
sha512sums = 7696a6874d17957f99452452723ae1a6b32b6814b018361a71ed1fe0191e1c6da6f3ad693e2e279615e74f687c380ff2f6dab8b69fcd82476e8f33b56a6b4cb5
diff --git a/PKGBUILD b/PKGBUILD
index 681e6c4d95d7..174de2e5ef6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,45 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=zulip-desktop-git
-pkgver=4.0.0+r2+gf8d93cf
+_pkgname=zulip-desktop
+pkgver=4.0.0+r19+gdae7089
pkgrel=1
pkgdesc='Real-time team chat based on the email threading model (git)'
arch=(i686 x86_64)
url=https://zulipchat.com
license=(Apache)
depends=(libxkbfile gtk3 libxss nss)
-makedepends=(git npm python2 typescript)
+makedepends=(git npm python2)
provides=(zulip-desktop)
-conflicts=(zulip-desktop zulip-desktop-bin)
-source=(git+https://github.com/zulip/${pkgname/-git/}
- zulip.desktop)
+conflicts=(zulip-desktop)
+source=(git+https://github.com/zulip/$_pkgname
+ $_pkgname.desktop)
sha512sums=('SKIP'
'7696a6874d17957f99452452723ae1a6b32b6814b018361a71ed1fe0191e1c6da6f3ad693e2e279615e74f687c380ff2f6dab8b69fcd82476e8f33b56a6b4cb5')
pkgver() {
- cd ${pkgname/-git/}
+ cd $_pkgname
git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
build() {
- cd ${pkgname/-git/}
+ cd $_pkgname
npm i
npm run pack
}
package() {
- cd ${pkgname/-git/}
+ cd $_pkgname
install -d "$pkgdir"/usr/{lib,bin}
- cp -a dist/linux-unpacked "$pkgdir"/usr/lib/${pkgname/-git/}
- ln -s /usr/lib/${pkgname/-git/}/zulip "$pkgdir"/usr/bin
+ cp -a dist/linux-unpacked "$pkgdir"/usr/lib/$_pkgname
+ ln -s /usr/lib/$_pkgname/zulip "$pkgdir"/usr/bin
- install -Dm 644 ../zulip.desktop -t "$pkgdir"/usr/share/applications
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
+
+ install -Dm 644 ../$_pkgname.desktop -t "$pkgdir"/usr/share/applications
for i in 16 24 32 48 64 96 128 256 512; do
install -Dm 644 build/icons/${i}x${i}.png \
"$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png
done
-
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/zulip-desktop
}
diff --git a/zulip.desktop b/zulip-desktop.desktop
index 4768ad88eaf6..4768ad88eaf6 100644
--- a/zulip.desktop
+++ b/zulip-desktop.desktop