summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuele 'Lele aka eldios' Calo2017-06-19 19:39:22 +0200
committerEmanuele 'Lele aka eldios' Calo2017-06-19 19:39:22 +0200
commita610c8f2701193968c14348b18ef903c7bd685e3 (patch)
tree694de0aad28badefe9b2a0cb5f483cc120645f41
parentd55f873f670be095f016e85aea161cc91f6dc8e0 (diff)
downloadaur-a610c8f2701193968c14348b18ef903c7bd685e3.tar.gz
Changed to zip-based installation process
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b892fead98fe..cc7d4f5c7026 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,21 @@
pkgname=zulip-electron-bin
pkgver=0.5.10
-pkgrel=2
+pkgrel=3
pkgdesc="Desktop client for Zulip. Available for Mac, Linux and Windows."
arch=('x86_64')
url="https://github.com/zulip/zulip-electron"
license=('Apache')
depends=('electron')
-source=("https://github.com/zulip/zulip-electron/releases/download/v${pkgver}/zulip-${pkgver}-x86_64.AppImage")
-sha256sums=('ef718c8fa63052ddec598395e792afe9687513300641c778f68a869ed87df4ed')
+source=("https://github.com/zulip/zulip-electron/releases/download/v${pkgver}/zulip-${pkgver}-linux.zip")
+sha256sums=('35e1f7e27300acf52a4a604c71aa752e2d455ced35b695215e55bc70013bff11')
package() {
- mkdir -p "${pkgdir}/usr/bin"
- install -Dm755 zulip-${pkgver}-x86_64.AppImage "$pkgdir/usr/bin/zulip-electron"
+ install -d "$pkgdir"/opt
+ cp -R "$srcdir"/linux-unpacked "$pkgdir"/opt/zulip-electron
+
+ install -d "$pkgdir"/usr/bin
+ ln -sf ../../opt/zulip-electron/zulip "$pkgdir"/usr/bin/zulip-electron
+
# no man pages, docs or web assets in release tarball
}