summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Guymer2019-08-05 22:15:25 +1000
committerSam Guymer2019-08-05 22:15:25 +1000
commitc2ba2025811d76b6b3e4fc44b4628d48e4ca89c8 (patch)
tree079c5e304a7999d50f6662eceb53e951ff854e56
parent8748f1b63a27a18665690a54a8cbc43f47fe6ed8 (diff)
downloadaur-c2ba2025811d76b6b3e4fc44b4628d48e4ca89c8.tar.gz
Update to 11.0.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b2dca9ba9dd..4b1ebee2df40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = zulu-11-bin
- pkgdesc = Zulu is a certified build of OpenJDK that is fully compliant with the Java SE standard.
- pkgver = 11.0.3
+ pkgdesc = Zulu Community builds of OpenJDK are fully certified and 100% open source Java Development Kits (JDKs) for all Java development and production workloads.
+ pkgver = 11.0.4
pkgrel = 1
- url = https://www.azul.com/zulu
+ url = https://www.azul.com/products/zulu-community/
install = zulu-11-bin.install
arch = x86_64
license = custom
@@ -14,13 +14,16 @@ pkgbase = zulu-11-bin
depends = libnet
depends = freetype2
depends = giflib
- depends = java-environment-common=3
depends = hicolor-icon-theme
depends = libelf
provides = java-environment=11
provides = java-environment-openjdk=11
- source = http://cdn.azul.com/zulu/bin/zulu11.31.11-ca-jdk11.0.3-linux_x64.tar.gz
- md5sums = 20218b15ae5ef1318aed1a3d5dde3219
+ provides = java-runtime-headless=11
+ provides = java-runtime-headless-openjdk=11
+ provides = java-runtime=11
+ provides = java-runtime-openjdk=11
+ source = https://cdn.azul.com/zulu/bin/zulu11.33.15-ca-jdk11.0.4-linux_x64.tar.gz
+ sha256sums = cd807601c93d2e9c0e524b251d277da0add8026c4a7fb9908c72dcc19135edc6
pkgname = zulu-11-bin
diff --git a/PKGBUILD b/PKGBUILD
index 38e5e71834a7..a03ba7157b1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,35 @@
_jdkname=zulu-11
pkgname="${_jdkname}-bin"
_java_ver=11
-_zulu_build=11.31.11-ca
-pkgver=11.0.3
+_zulu_build=11.33.15-ca
+pkgver=11.0.4
pkgrel=1
-pkgdesc='Zulu is a certified build of OpenJDK that is fully compliant with the Java SE standard.'
+pkgdesc='Zulu Community builds of OpenJDK are fully certified and 100% open source Java Development Kits (JDKs) for all Java development and production workloads.'
arch=('x86_64')
-url='https://www.azul.com/zulu'
+url='https://www.azul.com/products/zulu-community/'
license=('custom')
depends=(
+ 'java-runtime-common>=3' 'ca-certificates-utils'
# not 100% sure if all of these dependencies are needed
# dependencies from jre11-openjdk-headless
- 'java-runtime-common>=3' 'ca-certificates-utils' 'nss' 'libjpeg-turbo' 'lcms2' 'libnet' 'freetype2'
+ 'nss' 'libjpeg-turbo' 'lcms2' 'libnet' 'freetype2'
# dependencies from jre11-openjdk
'giflib'
# dependencies from java11-openjdk
- 'java-environment-common=3' 'hicolor-icon-theme' 'libelf'
+ 'hicolor-icon-theme' 'libelf'
)
provides=(
"java-environment=$_java_ver"
"java-environment-openjdk=$_java_ver"
+ "java-runtime-headless=$_java_ver"
+ "java-runtime-headless-openjdk=$_java_ver"
+ "java-runtime=$_java_ver"
+ "java-runtime-openjdk=$_java_ver"
)
install="$pkgname.install"
_tarballname="zulu${_zulu_build}-jdk${pkgver}-linux_x64"
-source=("http://cdn.azul.com/zulu/bin/${_tarballname}.tar.gz")
-md5sums=('20218b15ae5ef1318aed1a3d5dde3219')
+source=("https://cdn.azul.com/zulu/bin/${_tarballname}.tar.gz")
+sha256sums=('cd807601c93d2e9c0e524b251d277da0add8026c4a7fb9908c72dcc19135edc6')
_jvmdir="/usr/lib/jvm/${_jdkname}"