summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Guymer2020-12-02 16:34:17 +0000
committerSam Guymer2020-12-02 16:34:17 +0000
commited9d2b5a3cc779dc1a179a3b4e1cc1ccdfeb73f4 (patch)
treece8fe1a12876e5eecb5fdaf4bfb23bf2e87acbae
parent7e5e39bb5792fc449964784410e13437fa3e7767 (diff)
downloadaur-ed9d2b5a3cc779dc1a179a3b4e1cc1ccdfeb73f4.tar.gz
Update to 13.0.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ca78688e2a6..8bab9a2cb421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,22 @@
pkgbase = zulu-13-bin
pkgdesc = Zulu Community builds of OpenJDK are fully certified and 100% open source Java Development Kits (JDKs) for all Java development and production workloads.
- pkgver = 13.0.3
+ pkgver = 13.0.5
pkgrel = 1
url = https://www.azul.com/products/zulu-community/
install = zulu-13-bin.install
arch = x86_64
license = custom
- depends = java-environment-common=3
+ depends = java-environment-common>=3
depends = java-runtime-common>=3
depends = ca-certificates-utils
- depends = nss
- depends = libjpeg-turbo
- depends = lcms2
- depends = libnet
- depends = freetype2
- depends = giflib
- depends = hicolor-icon-theme
- depends = libelf
provides = java-environment=13
provides = java-environment-openjdk=13
provides = java-runtime-headless=13
provides = java-runtime-headless-openjdk=13
provides = java-runtime=13
provides = java-runtime-openjdk=13
- source = https://cdn.azul.com/zulu/bin/zulu13.31.11-ca-jdk13.0.3-linux_x64.tar.gz
- sha256sums = 3e5dc530c9e9466fc76b860d924876ea93bbdae80a12d47649e11dda3dbd9bac
+ source = https://cdn.azul.com/zulu/bin/zulu13.35.100-ca-jdk13.0.5-linux_x64.tar.gz
+ sha256sums = 835bce2cf2d6da6af0e681666a4eae319b6da13cb4949688cf55a5bbc239a81c
pkgname = zulu-13-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1986b04bac69..2c53aadf0248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,17 @@
_jdkname=zulu-13
pkgname="${_jdkname}-bin"
_java_ver=13
-_zulu_build=13.31.11-ca
-pkgver=13.0.3
+_zulu_build=13.35.17-ca
+pkgver=13.0.5
pkgrel=1
pkgdesc='Zulu Community builds of OpenJDK are fully certified and 100% open source Java Development Kits (JDKs) for all Java development and production workloads.'
arch=('x86_64')
url='https://www.azul.com/products/zulu-community/'
license=('custom')
depends=(
- 'java-environment-common=3' 'java-runtime-common>=3' 'ca-certificates-utils'
- # not 100% sure if all of these dependencies are needed
- # dependencies from jre13-openjdk-headless
- 'nss' 'libjpeg-turbo' 'lcms2' 'libnet' 'freetype2'
- # dependencies from jre13-openjdk
- 'giflib'
- # dependencies from java13-openjdk
- 'hicolor-icon-theme' 'libelf'
+ 'java-environment-common>=3'
+ 'java-runtime-common>=3'
+ 'ca-certificates-utils'
)
provides=(
"java-environment=$_java_ver"
@@ -31,7 +26,7 @@ provides=(
install="$pkgname.install"
_tarballname="zulu${_zulu_build}-jdk${pkgver}-linux_x64"
source=("https://cdn.azul.com/zulu/bin/${_tarballname}.tar.gz")
-sha256sums=('3e5dc530c9e9466fc76b860d924876ea93bbdae80a12d47649e11dda3dbd9bac')
+sha256sums=('98032f75751255ba01284f4e79796b3942db73e23eb899847a7c768f7547b9f0')
_jvmdir="/usr/lib/jvm/${_jdkname}"
@@ -46,11 +41,13 @@ package() {
# Conf
install -dm 755 "${pkgdir}/etc"
cp -r conf "${pkgdir}/etc/${_jdkname}"
+ rm -r "${pkgdir}/${_jvmdir}/conf"
ln -s "/etc/${_jdkname}" "${pkgdir}/${_jvmdir}/conf"
# Legal
install -dm 755 "${pkgdir}/usr/share/licenses"
cp -r legal "${pkgdir}/usr/share/licenses/${_jdkname}"
+ rm -r "${pkgdir}/${_jvmdir}/legal"
ln -s "/usr/share/licenses/${_jdkname}" "${pkgdir}/${_jvmdir}/legal"
# Man pages
@@ -59,6 +56,7 @@ package() {
_man=../jdk/man/man1/"${f}.1"
test -f "${_man}" && install -Dm 644 "${_man}" "${pkgdir}/usr/share/man/man1/${f}-${_jdkname}.1"
done
+ rm -r "${pkgdir}/${_jvmdir}/man"
ln -s /usr/share/man "${pkgdir}/${_jvmdir}/man"
# Link JKS keystore from ca-certificates-utils