summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHong Shick Pak2021-09-11 16:49:16 -0700
committerHong Shick Pak2021-09-11 16:49:16 -0700
commit6295e643bd69a0c0dd90aa2b4a541b5c8486b29e (patch)
tree3e432a2bf4fcf4be6c437ca86b09e38bcc6f4d07
parent5032cc9fa4dd55f6448823c0e1d4ae69ea5625eb (diff)
downloadaur-6295e643bd69a0c0dd90aa2b4a541b5c8486b29e.tar.gz
Fix 0.6.0 release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287ac8be3e4f..6bb0b29c559e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zur
pkgdesc = An AUR helper written in Zig
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hspak/zur
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = zur
provides = zur
conflicts = zur
conflicts = zur-git
- source = git+https://github.com/hspak/zur
- sha256sums = SKIP
+ source = https://github.com/hspak/zur/archive/refs/tags/0.6.0.tar.gz
+ sha256sums = 4ec682852201fc57f0f1938ca55ab38b8ffa319b17b1aaedefeba792c17d6b20
pkgname = zur
diff --git a/PKGBUILD b/PKGBUILD
index e0271b11d527..4bf621fe80fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zur
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="An AUR helper written in Zig"
arch=("x86_64")
url="https://github.com/hspak/zur"
@@ -14,23 +14,18 @@ conflicts=("$pkgname" "$pkgname-git")
source=("https://github.com/hspak/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=("4ec682852201fc57f0f1938ca55ab38b8ffa319b17b1aaedefeba792c17d6b20")
-pkgver() {
- cd "$(echo $pkgname | cut -d'-' -f1)"
- git describe --tags | sed 's/-/+/g'
-}
-
build() {
- cd "$(echo $pkgname | cut -d'-' -f1)"
+ cd "${pkgname}-${pkgver}"
zig build -Dversion="${pkgver}" -Drelease-safe=true
}
check() {
- cd "$(echo $pkgname | cut -d'-' -f1)"
+ cd "${pkgname}-${pkgver}"
zig-out/bin/zur --version
}
package() {
- cd "$(echo $pkgname | cut -d'-' -f1)"
+ cd "${pkgname}-${pkgver}"
install -D -m 0755 "zig-out/bin/zur" "${pkgdir}/usr/bin/zur"
install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}