summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilly Micieli2024-01-07 13:17:10 +0100
committerWilly Micieli2024-01-07 13:17:10 +0100
commit5a0fe0140d15a34c349f4f55ecad10e3e55cab04 (patch)
tree52fdab9311812b669645383460af97e1b512b538
parentdce9c1a934f9d0c71ca5ccfc6b181eaf5ee14c68 (diff)
downloadaur-5a0fe0140d15a34c349f4f55ecad10e3e55cab04.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2164c09920cc..ae8f73d836f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zuu
pkgdesc = A git hook test runner for rust programer
- pkgver = 5.0.5
+ pkgver = 5.0.6
pkgrel = 1
url = https://github.com/taishingi/zuu
arch = any
@@ -9,7 +9,7 @@ pkgbase = zuu
depends = wget
depends = git
provides = zuu
- source = 5.0.5.tar.gz::https://github.com/taishingi/zuu/archive/refs/tags/5.0.5.tar.gz
- sha256sums = b0f7f1bd13b4369e752b58b41d4940c0e6e2584a2433e42764814f2308679a84
+ source = 5.0.6.tar.gz::https://github.com/taishingi/zuu/archive/refs/tags/5.0.6.tar.gz
+ sha256sums = ccd14124a983117b416cb1e9a2d2fa7eb6676adcdfe8662b7de34abd98e3d75e
pkgname = zuu
diff --git a/PKGBUILD b/PKGBUILD
index 88136c46aa65..67c762b49e51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Willy Micieli <micieli@vivaldi.net>
pkgname=zuu
-pkgver=5.0.5
+pkgver=5.0.6
pkgrel=1
pkgdesc="A git hook test runner for rust programer"
provides=("zuu")
@@ -10,10 +10,16 @@ url="https://github.com/taishingi/zuu"
license=('GPL3')
depends=('rustup' 'wget' 'git')
source=("${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('b0f7f1bd13b4369e752b58b41d4940c0e6e2584a2433e42764814f2308679a84')
+sha256sums=('ccd14124a983117b416cb1e9a2d2fa7eb6676adcdfe8662b7de34abd98e3d75e')
+
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
package() {
cd "${pkgname}-${pkgver}"
- cargo build --release
- cargo install --path .
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
}