summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibaut Pérami2019-10-21 14:09:48 +0200
committerThibaut Pérami2019-10-21 15:07:51 +0200
commitcb02f44c0b44da5bbded8f7e99f6887d1cd960b3 (patch)
tree681be4c962daf00c6059bfcd7fe4732d5448594c
downloadaur-cb02f44c0b44da5bbded8f7e99f6887d1cd960b3.tar.gz
First commit v3.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee51bd1acd4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zydis
+ pkgdesc = The ultimate, open-source X86 & X86-64 decoder/disassembler library.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://zydis.re
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = gcc-libs
+ source = zydis::git+https://github.com/zyantific/zydis#tag=v3.0.0
+ sha256sums = SKIP
+
+pkgname = zydis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df7203fd8a64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thibaut Pérami <thibaut.perami@ens.fr>
+
+pkgname=zydis
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="The ultimate, open-source X86 & X86-64 decoder/disassembler library."
+arch=('x86_64')
+url="https://zydis.re"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cmake' 'git')
+source=("${pkgname%-git}"::'git+https://github.com/zyantific/zydis#tag=v3.0.0')
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "${pkgname}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -B build
+ cmake --build build
+}
+
+package() {
+ cd "${pkgname}/build"
+ make DESTDIR="${pkgdir}" install
+ # Maybe put that in a separate pakage.
+ cd "dependencies/zycore"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file