summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-10-16 22:21:40 +0200
committerAlexandre Bouvier2021-10-16 22:21:40 +0200
commitba6d2d2e0c292d8bde83820d1b1b56f9999c0b3a (patch)
treefc265e8ec4d2bbb75f5823c4b5c71fc876ccf259
parente835cb2a6b1b702373243741c39a120cb72395e0 (diff)
downloadaur-ba6d2d2e0c292d8bde83820d1b1b56f9999c0b3a.tar.gz
update to 3.1.0.r131.g746faa4
* unbundle zycore * use ninja
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e11c15ec1a2..c46830cc2999 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = zydis-git
pkgdesc = Fast and lightweight x86/x86-64 disassembler library
- pkgver = 3.1.0.r78.g8080ae5
+ pkgver = 3.1.0.r131.g746faa4
pkgrel = 1
url = https://zydis.re/
arch = x86_64
license = MIT
makedepends = cmake
makedepends = git
+ makedepends = ninja
+ makedepends = zycore-c>=1.0.0.r19.g6c93d9a
depends = glibc
- provides = zydis=3.1.0.r78.g8080ae5
+ provides = zydis=3.1.0.r131.g746faa4
provides = libZydis.so
conflicts = zydis
source = git+https://github.com/zyantific/zydis.git
- source = git+https://github.com/zyantific/zycore-c.git
- b2sums = SKIP
+ source = 0001-zydis-unbundle-zycore.patch::https://github.com/zyantific/zydis/pull/250.patch
b2sums = SKIP
+ b2sums = 4ea5883a235572cb2e090900c4a52ae41b54d2219eafc3336df8b3e4e2ac85247a216770ffdb64261873b53aaa5414fbdd67a5798c7cbec13e9fb3943ff3ff8e
pkgname = zydis-git
+ depends = glibc
+ depends = libZycore.so
diff --git a/PKGBUILD b/PKGBUILD
index 0c7c5789d5a7..737b68ae57b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=zydis
pkgname=$_pkgname-git
-pkgver=3.1.0.r78.g8080ae5
+pkgver=3.1.0.r131.g746faa4
pkgrel=1
pkgdesc='Fast and lightweight x86/x86-64 disassembler library'
arch=('x86_64')
url='https://zydis.re/'
license=('MIT')
depends=('glibc')
-makedepends=('cmake' 'git')
+makedepends=('cmake' 'git' 'ninja' 'zycore-c>=1.0.0.r19.g6c93d9a')
provides=("$_pkgname=$pkgver" 'libZydis.so')
conflicts=("$_pkgname")
source=(
"git+https://github.com/zyantific/$_pkgname.git"
- 'git+https://github.com/zyantific/zycore-c.git'
+ "0001-zydis-unbundle-zycore.patch::https://github.com/zyantific/$_pkgname/pull/250.patch"
)
b2sums=(
'SKIP'
- 'SKIP'
+ '4ea5883a235572cb2e090900c4a52ae41b54d2219eafc3336df8b3e4e2ac85247a216770ffdb64261873b53aaa5414fbdd67a5798c7cbec13e9fb3943ff3ff8e'
)
pkgver() {
@@ -26,26 +26,24 @@ pkgver() {
}
prepare() {
- cd $_pkgname
- git submodule init dependencies/zycore
- git config submodule.dependencies/zycore.url ../zycore-c
- git submodule update
+ patch -d $_pkgname -Np1 < 0001-zydis-unbundle-zycore.patch
}
build() {
- cmake -S $_pkgname -B build \
+ cmake -S $_pkgname -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DZYDIS_BUILD_SHARED_LIB=ON \
-DZYDIS_FEATURE_AVX512=OFF \
-DZYDIS_FEATURE_KNC=OFF \
+ -DZYDIS_SYSTEM_ZYCORE=ON \
-Wno-dev
cmake --build build
}
package() {
+ depends+=('libZycore.so')
# shellcheck disable=SC2154
DESTDIR="$pkgdir" cmake --install build
- DESTDIR="$pkgdir" cmake --install build/zycore
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname $_pkgname/LICENSE
}