summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Borchers2017-05-14 07:57:17 +0200
committerRene Borchers2017-05-14 07:57:17 +0200
commit3768e89fb1ad299fafe4ab9d8044971c202128be (patch)
treeb72b4729b7c3b1aa2b055b40a7afc592545b6d26
parent07ba31a19e7ed0bc778d431942fc86c14a012422 (diff)
downloadaur-3768e89fb1ad299fafe4ab9d8044971c202128be.tar.gz
Added DLAGENTS line: You can only download after visiting index.html and getting a cookie.
Replaced build() function with package() function.
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec98b7857090..799708e578ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,15 @@ pkgdesc="High resolution maps for zyGrib"
arch=('any')
url="http://www.zygrib.org/"
license=('GPL')
-depends=('zygrib')
+depends=()
source=(zygrib_maps$pkgver.tgz::http://www.zygrib.org/getfile.php?file=zyGrib_maps$pkgver.tgz)
md5sums=('43324f8e8c7e9aa4e2f12dea4ae25d49')
-build() {
+# site works with cookies, which forces you to visit index.html first for the cookie
+DLAGENTS=('http::/usr/bin/curl -fLC - --cookie nada -o /dev/null %u --next --cookie nada --retry-delay 3 -o %o %u')
+
+package() {
install -d -m 755 $pkgdir/opt/zygrib/data/maps/gshhs
# README files already exist in package zygrib so we don't copy *
- install -m644 $srcdir/data/maps/gshhs/*.{rim,cat,cel,b} $pkgdir/opt/zygrib/data/maps/gshhs
-}
-
+ install -m 644 $srcdir/data/maps/gshhs/*.{rim,cat,cel,b} $pkgdir/opt/zygrib/data/maps/gshhs
+ }