summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvaloq2022-11-25 08:39:47 +0100
committervaloq2022-11-25 08:39:47 +0100
commit9cc1d32dab3fc9b91410add05966536c2529302c (patch)
tree08da9c97a5f841d697b757a81dff7f47d8bf62b5
downloadaur-9cc1d32dab3fc9b91410add05966536c2529302c.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81aa9c05c59c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zypak
+ pkgdesc = Redirect natively sandboxed applications to use a custom sandbox environment
+ pkgver = v2022.04
+ pkgrel = 1
+ url = https://github.com/refi64/zypak
+ arch = x86_64
+ license = BSD
+ depends = systemd
+ depends = dbus
+ provides = zypak
+ source = zypak-v2022.04::git+https://github.com/refi64/zypak
+ sha256sums = SKIP
+
+pkgname = zypak
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b846c3e3569
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: valoq <valoq@mailbox.org>
+
+pkgname=zypak
+pkgver=v2022.04
+pkgrel=1
+_commit='55a60d110301e8dd37b631503c3524ab7baaf7aa'
+pkgdesc="Redirect natively sandboxed applications to use a custom sandbox environment"
+arch=('x86_64')
+url="https://github.com/refi64/zypak"
+license=('BSD')
+depends=('systemd' 'dbus')
+makedepends=()
+provides=('zypak')
+source=("$pkgname-$pkgver::git+https://github.com/refi64/zypak")
+
+## using git commit hash
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ git checkout ${_commit}
+ git submodule init
+ git submodule update --init --recursive
+
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ## upstreams configure does not do anything yet
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/usr/" FLATPAK_DEST="$pkgdir/usr/" install
+ cd $pkgdir/usr/bin/
+ ln -sf zypak-wrapper.sh zypak-wrapper
+}