summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-01-18 04:07:33 +0100
committeranthraxx2016-01-18 04:07:33 +0100
commit239c49da079c1fad77a2e39be91f8fcd2e3a79be (patch)
treee745ece85b2600fcf6c03f9770fd9222495fa222
downloadaur-239c49da079c1fad77a2e39be91f8fcd2e3a79be.tar.gz
addpkg: zzuf-git 0.14.669.d16576b-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..462d4d5fd6ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 03:07:33 UTC 2016
+pkgbase = zzuf-git
+ pkgdesc = Transparent application input fuzzer
+ pkgver = 0.14.669.d16576b
+ pkgrel = 1
+ url = https://github.com/samhocevar/zzuf
+ arch = i686
+ arch = x86_64
+ license = custom:WTF
+ makedepends = git
+ depends = glibc
+ provides = zzuf
+ conflicts = zzuf
+ source = zzuf-git::git+https://github.com/samhocevar/zzuf
+ sha512sums = SKIP
+
+pkgname = zzuf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68ef065dfa40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=zzuf-git
+pkgver=0.14.669.d16576b
+pkgrel=1
+pkgdesc="Transparent application input fuzzer"
+url='https://github.com/samhocevar/zzuf'
+arch=('i686' 'x86_64')
+license=('custom:WTF')
+depends=('glibc')
+makedepends=('git')
+provides=('zzuf')
+conflicts=('zzuf')
+source=(${pkgname}::git+https://github.com/samhocevar/zzuf)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ autoreconf -fiv
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd ${pkgname}
+ # ignore test results because of upstream bug #7
+ make check||true
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: