summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:14:06 +0300
committerAchilleas Pipinellis2015-06-10 09:14:06 +0300
commit0008708d5c40ebd710380ee70925b978876c5343 (patch)
tree5ea7c9616ae7c1d4f449e5aab9021425c698c5bc
downloadaur-0008708d5c40ebd710380ee70925b978876c5343.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38f6f2155fb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-fswrap
+ pkgdesc = An opinionated wrapper on file system and path functions
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/lakshmivyas/fswrap
+ arch = any
+ license = MIT
+ makedepends = python2
+ makedepends = python2-distribute
+ source = http://pypi.python.org/packages/source/f/fswrap/fswrap-0.1.2.tar.gz
+ md5sums = f0654c3c3277316f691af7339fdadfb3
+
+pkgname = python2-fswrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..157468eb3962
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Axilleas P <axilleas archlinux info>
+
+pkgname=python2-fswrap
+_pkgname=fswrap
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="An opinionated wrapper on file system and path functions"
+url="https://github.com/lakshmivyas/fswrap"
+arch=('any')
+license=('MIT')
+makedepends=('python2' 'python2-distribute')
+source=(http://pypi.python.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz)
+
+prepare() {
+ cd ${srcdir}/$_pkgname-$pkgver
+ sed -i 's|#!python|#!/usr/bin/env python2|' distribute_setup.py
+}
+
+package() {
+ cd ${srcdir}/$_pkgname-$pkgver
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 setup.py install --root="${pkgdir}" -O1
+}
+md5sums=('f0654c3c3277316f691af7339fdadfb3')