summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShinyzenith2022-07-30 03:16:46 +0530
committerShinyzenith2022-07-30 03:16:46 +0530
commit001c66643266a8f99eb678b2fddd925b71c20695 (patch)
tree0382bea0d9c8a8595c99ca5d53e26b120d47aa08
parenta7c816587e931431299e813157fa699b75d47663 (diff)
downloadaur-001c66643266a8f99eb678b2fddd925b71c20695.tar.gz
man
Signed-off-by: Shinyzenith <aakashsensharma@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b8205d49aeb..950bfe9dd363 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = wayshot-bin
provides = wayshot-bin
conflicts = wayshot-git
conflicts = wayshot-musl-git
- source = wayshot::https://github.com/waycrate/wayshot/releases/download/1.1.9/wayshot
+ source = wayshot-bin::https://github.com/waycrate/wayshot/releases/download/1.1.9/wayshot
+ source = wayshot-src::git+https://git.sr.ht/~shinyzenith/wayshot
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = wayshot-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1545f31dc9ba..4ba4b698d6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Aakash Sen Sharma <aakashsensharma@gmail.com>
pkgname=wayshot-bin
+_pkgname=wayshot
pkgver=1.1.9
pkgrel=1
pkgdesc="A screenshot tool for wlroots compositors."
@@ -9,10 +10,21 @@ arch=('x86_64')
optdepends=('slurp: for area selection')
provides=('wayshot-bin')
conflicts=('wayshot-git' 'wayshot-musl-git')
-source=("wayshot::$url/releases/download/$pkgver/wayshot")
-sha256sums=('SKIP')
+source=("$_pkgname-bin::$url/releases/download/$pkgver/$_pkgname"
+ "$_pkgname-src::git+https://git.sr.ht/~shinyzenith/$_pkgname"
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ )
-package() {
- install -Dm 755 wayshot "$pkgdir/usr/bin/wayshot"
+build() {
+ cd $_pkgname-src
+ rustc ./build.rs
+ ./build 1>/dev/null 2>/dev/null 3>/dev/null
}
+package() {
+ install -Dm 755 $_pkgname-bin "$pkgdir/usr/bin/$_pkgname"
+ install -Dm 644 ./$_pkgname-src/docs/*.1.gz "$pkgdir/usr/share/man/man1"
+ install -Dm 644 ./$_pkgname-src/docs/*.7.gz "$pkgdir/usr/share/man/man7"
+}