summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2015-06-10 14:04:04 +0300
committerMatti Niemenmaa2015-07-14 16:19:13 +0300
commit0020b937c6ba3474e67ef87cda41a3afa1b87122 (patch)
treea48a7119042b5bf0a0cf6257a189adbedf2e9550
parent883f98628c8ca99dd0c35da8f06c9ef289d8b178 (diff)
downloadaur-0020b937c6ba3474e67ef87cda41a3afa1b87122.tar.gz
Link with -Bsymbolic to reduce symbol leak issues
Plenty of internal symbols are exported, with rather generic names that can (and do) conflict with other libraries. So link with -Bsymbolic, which prevents overriding them with LD_PRELOAD but also prevents such conflicts from causing problems with functions here accidentally calling some other library's functions.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--makefiles.patch4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7e5182027e2..80c7997fa4a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = mdxmini-git
source = mdxmini-git::git+https://github.com/BouKiCHi/mdxplayer.git
source = makefiles.patch
sha256sums = SKIP
- sha256sums = 2c67ce4f2828b11c785eae52c874a06ad535ad8e762d4b70230959ed9217840b
+ sha256sums = d8f24d0a385ed081e496573abed032366a2e74c6ea4c6dada80d7571e40bf1c0
pkgname = mdxmini-git
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index e9214477c768..3e8b43f90ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ makedepends=(git)
source=("$pkgbase"::'git+https://github.com/BouKiCHi/mdxplayer.git'
makefiles.patch)
sha256sums=('SKIP'
- '2c67ce4f2828b11c785eae52c874a06ad535ad8e762d4b70230959ed9217840b')
+ 'd8f24d0a385ed081e496573abed032366a2e74c6ea4c6dada80d7571e40bf1c0')
pkgver() {
cd "$srcdir/$pkgbase"
diff --git a/makefiles.patch b/makefiles.patch
index a790cd1c5c20..47fcd588cd9a 100644
--- a/makefiles.patch
+++ b/makefiles.patch
@@ -30,7 +30,7 @@ index e56323b..fff9e7c 100644
#
diff --git i/jni/mdxmini/mak/lib.mak w/jni/mdxmini/mak/lib.mak
-index 38af592..bee1432 100644
+index 38af592..c24a1af 100644
--- i/jni/mdxmini/mak/lib.mak
+++ w/jni/mdxmini/mak/lib.mak
@@ -3,13 +3,13 @@ LIB = $(OBJDIR)/libmdxmini.a
@@ -54,7 +54,7 @@ index 38af592..bee1432 100644
$(AR) rcs $@ $(OBJS)
+$(OBJDIR)/libmdxmini.so : $(OBJS)
-+ $(CC) $(CFLAGS) -shared -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) -Wl,-Bsymbolic -shared -o $@ $^ $(LIBS)
+
$(OBJDIR)/%.o : $(SRCDIR)/%.c
$(CC) $(CFLAGS) -o $@ $< -c