summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2019-08-11 22:05:13 +0200
committerChristian Muehlhaeuser2019-08-11 22:05:13 +0200
commit0027a3b05570667ff5b59f79713cdc7c463e7bf5 (patch)
tree97b5cc12d5539e6b3db06df468cfefe780530dc7
downloadaur-0027a3b05570667ff5b59f79713cdc7c463e7bf5.tar.gz
Initial commit for package mastotool
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbec9d78d014
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mastotool
+ pkgdesc = a collection of tools to work with your Mastodon account
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/muesli/mastotool
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ options = !makeflags
+ source = mastotool-0.1::git+https://github.com/muesli/mastotool#tag=v0.1
+ sha256sums = SKIP
+
+pkgname = mastotool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60fa748ae85b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
+
+pkgname=mastotool
+pkgver=0.1
+pkgrel=1
+pkgdesc="a collection of tools to work with your Mastodon account"
+arch=('x86_64' 'i686')
+url="https://github.com/muesli/mastotool"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs' '!makeflags')
+source=("$pkgname-$pkgver::git+https://github.com/muesli/mastotool#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ export GO111MODULE=on
+ cd "$srcdir"/$pkgname-$pkgver
+ go build
+}
+
+package() {
+ # Install binary
+ install -Dm755 "$pkgname-$pkgver/mastotool" "$pkgdir/usr/bin/mastotool"
+}
+
+# vim:set ts=4 sw=4 et: