summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2016-01-03 20:36:13 +0200
committerGordonGR2016-01-03 20:36:13 +0200
commit004aac5a5f3e6853b5f3dac5fd6d32bd4f8095c9 (patch)
tree4f9b87778c9d30c3eb8efb56649d5e584978f2fa
parent8ab047e8cd94ed932bb88f9e70927d30b01e63ba (diff)
downloadaur-004aac5a5f3e6853b5f3dac5fd6d32bd4f8095c9.tar.gz
1:2.4.r96.fa8646d-1: Upstream update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD56
2 files changed, 50 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64d9249b3d00..d09305bd26bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Jan 3 18:35:42 UTC 2016
pkgbase = lib32-rtmpdump
- pkgdesc = A tool to download rtmp streams (32 bit)
- pkgver = 20140918
+ pkgdesc = Tool to download rtmp streams (lib32)
+ pkgver = 2.4.r96.fa8646d
pkgrel = 1
+ epoch = 1
url = http://rtmpdump.mplayerhq.hu/
arch = x86_64
license = GPL2
license = LGPL2.1
makedepends = git
+ depends = lib32-glibc
depends = lib32-openssl
+ depends = lib32-zlib
depends = rtmpdump
+ provides = librtmp.so
options = !makeflags
- source = git://git.ffmpeg.org/rtmpdump#commit=a1900c3
- md5sums = SKIP
+ source = git://git.ffmpeg.org/rtmpdump#commit=fa8646d
+ sha256sums = SKIP
pkgname = lib32-rtmpdump
diff --git a/PKGBUILD b/PKGBUILD
index 1cf102900c36..b7c81ac0a965 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,58 @@
-# Contributor: josephgbr <rafael.f.f1@gmail.com>
# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: xduugu
+# Contributor: Elis Hughes <elishughes@googlemail.com>
+pkgname=lib32-rtmpdump
_pkgname=rtmpdump
-pkgname=lib32-${_pkgname}
-pkgver=20140918
+pkgver=2.4.r96.fa8646d
pkgrel=1
-pkgdesc="A tool to download rtmp streams (32 bit)"
+epoch=1
+pkgdesc='Tool to download rtmp streams (lib32)'
arch=('x86_64')
-url="http://rtmpdump.mplayerhq.hu/"
+url='http://rtmpdump.mplayerhq.hu/'
license=('GPL2' 'LGPL2.1')
-depends=('lib32-openssl' "${_pkgname}")
+depends=('lib32-glibc' 'lib32-openssl' 'lib32-zlib' "${_pkgname}")
makedepends=('git')
+provides=('librtmp.so')
options=('!makeflags')
-source=(git://git.ffmpeg.org/rtmpdump#commit=a1900c3)
-md5sums=('SKIP')
-options=(!makeflags)
+_commit='fa8646d'
+source=("git://git.ffmpeg.org/rtmpdump#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+cd rtmpdump
+_ver_name='2.4'
+_ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+
+echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+}
prepare() {
-cd ${_pkgname}
+cd rtmpdump
sed -i -e 's:gcc:gcc -m32:' Makefile librtmp/Makefile
+sed -i -e 's/host_cpu\=\"\${host\%\%-\*}\"/host_cpu\="i386"/' Makefile librtmp/Makefile
+sed -i -e 's/march\=\"\${march\%\%-\*}\"/march\="i386"/' Makefile librtmp/Makefile
}
build() {
-cd ${_pkgname}
-make OPT="$CFLAGS" XLDFLAGS="$LDFLAGS"
+cd rtmpdump
+make \
+ OPT="$CFLAGS" \
+ XLDFLAGS="$LDFLAGS"
}
package() {
-cd ${_pkgname}
-install -dm755 "${pkgdir}/usr/lib32"
-make prefix=/usr mandir=/usr/share/man libdir=/usr/lib32 DESTDIR="${pkgdir}" install
+cd rtmpdump
+make \
+ prefix='/usr' \
+ sbindir='/usr/bin' \
+ mandir='/usr/share/man' \
+ DESTDIR="${pkgdir}" \
+ libdir='/usr/lib32' \
+ install
+
rm -rf "${pkgdir}/usr"/{bin,include,sbin,share}
-}
+
+} \ No newline at end of file