summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-12-17 21:41:06 -0600
committerLuis Martinez2022-12-17 21:41:06 -0600
commit005b6ecff51d990460d36b6f5febd37e862a2bfa (patch)
tree5b3366b088a2163e020e2c5385b62a167d0ab4ab
parent161ed99b337874a299c4ac65e88bd41b95a93779 (diff)
downloadaur-005b6ecff51d990460d36b6f5febd37e862a2bfa.tar.gz
update to 2.4.166
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.txt25
-rw-r--r--PKGBUILD12
3 files changed, 37 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b9c44cd2c88..0ec22a50788d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pymisp
pkgdesc = Python library to access MISP platforms via their REST API
- pkgver = 2.4.165.1
+ pkgver = 2.4.166
pkgrel = 1
url = https://github.com/MISP/PyMISP
changelog = CHANGELOG.txt
arch = any
license = BSD
makedepends = git
- makedepends = python-poetry-core
makedepends = python-build
makedepends = python-installer
+ makedepends = python-poetry-core
makedepends = python-setuptools
makedepends = python-wheel
depends = python-dateutil
@@ -27,7 +27,7 @@ pkgbase = python-pymisp
optdepends = python-urllib3: python-pymisp[brotli] support
optdepends = python-validators: python-pymisp[virustotal] support
optdepends = python-reportlab: python-pymisp[reportlab] support
- source = python-pymisp::git+https://github.com/MISP/PyMISP#tag=v2.4.165.1?signed
+ source = python-pymisp::git+https://github.com/MISP/PyMISP#tag=v2.4.166?signed
source = remove-datafiles.patch
validpgpkeys = 8647F5A7FFD350AE38B6E22F32E4E1C133B3792F
sha256sums = SKIP
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 599414a85260..235a1b4b3267 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -2,11 +2,36 @@ Changelog
=========
+v2.4.166 (2022-11-28)
+---------------------
+
+New
+~~~
+- Basic support for listing, enabling and disabling decaying models.
+ [Raphaël Vinot]
+- [tests] Test for local tags. [Raphaël Vinot]
+
+Changes
+~~~~~~~
+- Bump changelog. [Raphaël Vinot]
+- Bump deps, version. [Raphaël Vinot]
+- [types] added azure-application-id. [iglocska]
+- Bump deps. [Raphaël Vinot]
+- Bump deps. [Raphaël Vinot]
+- Bump deps. [Raphaël Vinot]
+
+Fix
+~~~
+- [describetypes] updated with the latest output from MISP. [iglocska]
+- [types] added missing type value. [iglocska]
+
+
v2.4.165.1 (2022-11-10)
-----------------------
Changes
~~~~~~~
+- Bump changelog. [Raphaël Vinot]
- Bump deps. [Raphaël Vinot]
Fix
diff --git a/PKGBUILD b/PKGBUILD
index cbb9e4cdaf06..af6135053f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-pymisp
_pkg="${pkgname#python-}"
-pkgver=2.4.165.1
+pkgver=2.4.166
pkgrel=1
pkgdesc="Python library to access MISP platforms via their REST API"
arch=('any')
@@ -27,7 +27,13 @@ optdepends=(
'python-urllib3: python-pymisp[brotli] support'
'python-validators: python-pymisp[virustotal] support'
'python-reportlab: python-pymisp[reportlab] support')
-makedepends=('git' 'python-poetry-core' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-poetry-core'
+ 'python-setuptools'
+ 'python-wheel')
changelog=CHANGELOG.txt
source=("$pkgname::git+$url#tag=v$pkgver?signed"
'remove-datafiles.patch')
@@ -52,7 +58,7 @@ build() {
package() {
cd "$pkgname"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -dv "$pkgdir/usr/share/licenses/$pkgname/"
ln -sv \