summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum Parsey2023-06-25 00:41:12 +0930
committerCallum Parsey2023-06-25 00:41:12 +0930
commit0081f0f9736e2a080622f2c5ab265d8fef1ce980 (patch)
tree89a650e99244106a9d3578de74558ce86e4f0cf6
parentf7fc7cf28a86d308be3c4b26b60889f1db486ccd (diff)
downloadaur-0081f0f9736e2a080622f2c5ab265d8fef1ce980.tar.gz
Remove unneeded files from package
Namely the `quotest` program and the Android NDK build files, as those will conflict with the official `libquotient` package regardless of how we change the name/location of the headers/library.
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76751b643e12..7fbfde65d18f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None \
-DBUILD_SHARED_LIBS=1 \
+ -DBUILD_TESTING=OFF \
-DQuotient_ENABLE_E2EE=ON
cmake --build build
@@ -28,4 +29,11 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build
install -Dm 644 "libQuotient-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # NOTE: There does not seem to be a way to inhibit generating the
+ # Android Native Development Kit (NDK) build file without patching
+ # libQuotient's build script. This file has a generic name which
+ # will conflict with the official `libquotient` package, so it must
+ # therefore be removed manually.
+ rm -r "${pkgdir}/usr/share/ndk-modules"
}