summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-07-29 11:26:04 +1200
committercaltlgin2020-07-29 11:26:04 +1200
commit00e25fae9e7e62adfd02642c24499d162d6285df (patch)
tree67c7d62b8ecc566c76134cbdfa254bd6841b110b
downloadaur-00e25fae9e7e62adfd02642c24499d162d6285df.tar.gz
Add to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f2529d2b12a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-savepagenow
+ pkgdesc = Wrapper for archive.org Save Page Now capturing service
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/pastpages/savepagenow/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-click
+ depends = python-requests
+ source = savepagenow-1.0.1.tar.gz::https://github.com/pastpages/savepagenow//archive/v1.0.1.tar.gz
+ sha256sums = 125037683da5b9429dfbe826d89eed0cb325ee8c326fb6abd707600cc8a1242e
+
+pkgname = python-savepagenow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e817b8153531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=savepagenow
+pkgname=python-${_pkgname}
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Wrapper for archive.org Save Page Now capturing service'
+arch=('any')
+url='https://github.com/pastpages/savepagenow/'
+license=('MIT')
+depends=('python-click' 'python-requests')
+makedepends=('python-setuptools')
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('125037683da5b9429dfbe826d89eed0cb325ee8c326fb6abd707600cc8a1242e')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 'README.rst' "${pkgdir}/usr/share/doc/${_pkgname}/README.rst"
+ install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: