summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-03-19 15:05:42 +0300
committerCaleb Maclennan2024-03-19 15:05:42 +0300
commit00f210032b6cdf139e5ed42b4fcfa65c35fbf33a (patch)
treea8bfa03915697346104d8ee5bb970604621cc885
parent527eb2776826c03cea32607112237a21c0b098c6 (diff)
downloadaur-00f210032b6cdf139e5ed42b4fcfa65c35fbf33a.tar.gz
upgpkg: ttfautohint-git 1.8.4.r13.g87a4ebf-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b1ec44fb836..450314f972f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ttfautohint-git
pkgdesc = Provides automated hinting process for web fonts
- pkgver = 1.8.3.r16.g701aa67
- pkgrel = 4
+ pkgver = 1.8.4.r13.g87a4ebf
+ pkgrel = 1
url = http://www.freetype.org/ttfautohint
arch = x86_64
arch = i686
- license = GPL
- license = custom
+ license = GPL-2.0-or-later OR FTL
+ makedepends = git
makedepends = imagemagick
makedepends = inkscape
makedepends = noto-fonts
@@ -16,7 +16,7 @@ pkgbase = ttfautohint-git
depends = freetype2
depends = harfbuzz
depends = qt5-base
- provides = ttfautohint=1.8.3.r16.g701aa67
+ provides = ttfautohint=1.8.4.r13.g87a4ebf
conflicts = ttfautohint
source = ttfautohint-git::git://repo.or.cz/ttfautohint.git
source = gnulib-git::git+https://git.savannah.gnu.org/git/gnulib.git
diff --git a/PKGBUILD b/PKGBUILD
index 585325e4268b..959078ed47eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
# Contributor: Arthur Titeica <arthur dot titeica at gmail dot com>
pkgname=ttfautohint-git
-pkgver=1.8.3.r16.g701aa67
-pkgrel=4
+pkgver=1.8.4.r13.g87a4ebf
+pkgrel=1
pkgdesc='Provides automated hinting process for web fonts'
arch=(x86_64 i686)
url="http://www.freetype.org/${pkgname%-git}"
-license=(GPL custom)
+license=('GPL-2.0-or-later OR FTL')
depends=(freetype2
harfbuzz
qt5-base)
-makedepends=(imagemagick
+makedepends=(git
+ imagemagick
inkscape
noto-fonts
pandoc
@@ -25,21 +26,20 @@ source=("$pkgname::git://repo.or.cz/${pkgname/-/.}"
sha256sums=('SKIP'
'SKIP')
-pkgver() {
- cd "$pkgname"
- git describe --tags --abbrev=7 --match="v*" HEAD |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
prepare(){
cd "$pkgname"
git submodule init
git config submodule.gnulib.url "$srcdir/gnulib-git"
- git submodule update
- echo "GNULIB_URL='$srcdir/gnulib-git'" > bootstrap.conf
+ git -c protocol.file.allow=always submodule update
./bootstrap --force
}
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --abbrev=7 --match="v*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$pkgname"
export QMAKE='/usr/bin/qmake'
@@ -48,6 +48,7 @@ build() {
export RCC='/usr/bin/rcc'
export TTFONTS='/usr/share/fonts/noto'
./configure \
+ --without-doc \
--prefix=/usr \
--with-qt=/usr/lib/qt \
--with-freetype-config="pkg-config freetype2"