summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2023-12-23 12:38:55 +0100
committergileri2023-12-23 12:38:55 +0100
commit00f320cbb9e11738eb0721602059b45ad1c7df34 (patch)
tree5e845f48a46bba1674bff7c609732d5c59bf9d68
parentb36211cd3082a5a891520447d8150f4f552a0b36 (diff)
downloadaur-00f320cbb9e11738eb0721602059b45ad1c7df34.tar.gz
Do not strip package, enable libbactrace
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c22d00a6ae20..425dc5d33f51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cataclysm-dda-git
pkgdesc = A post-apocalyptic roguelike.
- pkgver = 0.G.2023.08.25
+ pkgver = 0.G.2023.12.23
pkgrel = 1
url = https://cataclysmdda.org/
arch = i686
@@ -11,6 +11,7 @@ pkgbase = cataclysm-dda-git
makedepends = sdl2_mixer
makedepends = freetype2
makedepends = git
+ makedepends = libbacktrace-git
depends = ncurses
depends = gettext
optdepends = sdl2_image: for tiles
@@ -20,6 +21,7 @@ pkgbase = cataclysm-dda-git
conflicts = cataclysm-dda
conflicts = cataclysm-dda-ncurses
conflicts = cataclysm-dda-tiles
+ options = !strip
source = https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1b42dbf8323a..66d8efb3f066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-git
-pkgver=0.G.2023.08.25
+pkgver=0.G.2023.12.23
_pkgver=0.G
pkgrel=1
pkgdesc="A post-apocalyptic roguelike."
@@ -16,11 +16,12 @@ arch=('i686' 'x86_64')
license=("CCPL:by-sa")
conflicts=('cataclysm-dda' 'cataclysm-dda-ncurses' 'cataclysm-dda-tiles')
depends=('ncurses' 'gettext')
-makedepends=('sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'git')
+makedepends=('sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'git' 'libbacktrace-git')
optdepends=('sdl2_image: for tiles'
'sdl2_ttf: for tiles'
'freetype2: for tiles'
'sdl2_mixer: for tiles')
+options=('!strip')
#source=("$pkgname"::'git://github.com/CleverRaven/Cataclysm-DDA.git#branch=master')
# The git repo is more than a GB
# so download a snapshot while waiting for shallow clone support in makepkg
@@ -44,8 +45,8 @@ prepare() {
build() {
cd "Cataclysm-DDA-master"
- CXXFLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized" make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 TESTS=0 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0
- CXXFLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized" make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 TESTS=0 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0 TILES=1 SOUND=1
+ CXXFLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized" make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 TESTS=0 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0 LIBBACKTRACE=1
+ CXXFLAGS="$CXXFLAGS -Wno-error=maybe-uninitialized" make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 TESTS=0 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0 TILES=1 SOUND=1 LIBBACKTRACE=1
# LOCALIZE = 0 to save 30MB
# DYNAMIC_LINKING = 1 ?