summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSudokamikaze2016-12-21 19:08:59 +0200
committerSudokamikaze2016-12-21 19:08:59 +0200
commit0113361564d1810ea7bd06ee7aecba2c764d8085 (patch)
tree2e08fb3c7a8bf19d5984aa361d7d658f6975617c
downloadaur-0113361564d1810ea7bd06ee7aecba2c764d8085.tar.gz
initial
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD50
-rw-r--r--alsaequal.install14
-rw-r--r--alsaequal.patch13
-rw-r--r--false_error.patch13
-rw-r--r--fix-lib32-makefile.patch59
-rw-r--r--lib32-alsaequal_caps_9.x.patch22
7 files changed, 196 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..176afc7382f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lib32-alsaequal
+ pkgdesc = A real-time adjustable equalizer plugin for ALSA sound server.
+ pkgver = 0.6
+ pkgrel = 16
+ url = http://www.thedigitalmachine.net/alsaequal.html
+ install = alsaequal.install
+ arch = x86_64
+ license = GPL2
+ depends = lib32-alsa-lib
+ depends = lib32-ladspa
+ optdepends = lib32-caps: to use the Eq CAPS equalizer (10-band)
+ optdepends = lib32-swh-plugins: to use the mbeq equalizer (15-band)
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/alsaequal_0.6.orig.tar.bz2
+ source = false_error.patch
+ source = alsaequal.patch
+ source = fix-lib32-makefile.patch
+ source = lib32-alsaequal_caps_9.x.patch
+ md5sums = d2edc7710c72cbf3ab297c414e35ebda
+ md5sums = 15bbaaa51bf3e01fdc1af1cd3b0b53e3
+ md5sums = 40911a2eedc8fdb85b68bb81ccea65eb
+ md5sums = 9b58c23a264e59b672eccbf3f8c0663b
+ md5sums = 212e7c8bf7cb2f83b476894dde58812b
+
+pkgname = lib32-alsaequal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc7a9c318981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Pulshen Sudokamikaze <pulshencode@outlook.com>
+
+pkgname=lib32-alsaequal
+pkgver=0.6
+pkgrel=16
+pkgdesc="A real-time adjustable equalizer plugin for ALSA sound server."
+arch=('x86_64')
+url="http://www.thedigitalmachine.net/alsaequal.html"
+license=('GPL2')
+depends=('lib32-alsa-lib' 'lib32-ladspa')
+optdepends=('lib32-caps: to use the Eq CAPS equalizer (10-band)'
+ 'lib32-swh-plugins: to use the mbeq equalizer (15-band)')
+install='alsaequal.install'
+
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/alsaequal_${pkgver}.orig.tar.bz2"
+ 'false_error.patch'
+ 'alsaequal.patch'
+ 'fix-lib32-makefile.patch'
+ 'lib32-alsaequal_caps_9.x.patch')
+
+md5sums=('d2edc7710c72cbf3ab297c414e35ebda'
+ '15bbaaa51bf3e01fdc1af1cd3b0b53e3'
+ '40911a2eedc8fdb85b68bb81ccea65eb'
+ '9b58c23a264e59b672eccbf3f8c0663b'
+ '212e7c8bf7cb2f83b476894dde58812b')
+
+prepare() {
+ cd "$srcdir/${pkgname##*-}"
+
+ patch -Np0 -i ../false_error.patch
+ patch -Np0 -i ../alsaequal.patch
+ patch -Np1 -i ../fix-lib32-makefile.patch
+ patch -Np0 -i ../lib32-alsaequal_caps_9.x.patch
+
+ make clean
+}
+
+build() {
+ cd "${srcdir}/${pkgname##*-}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname##*-}"
+
+ mkdir -p "$pkgdir"/usr/lib32/alsa-lib/
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/alsaequal.install b/alsaequal.install
new file mode 100644
index 000000000000..332a6870fe00
--- /dev/null
+++ b/alsaequal.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "You should go to http://www.thedigitalmachine.net/alsaequal.html"
+ echo "to learn how to configure alsa to take benefit of this package."
+ /bin/true
+}
+
+post_upgrade() {
+ post_install
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/alsaequal.patch b/alsaequal.patch
new file mode 100644
index 000000000000..bf735b27adde
--- /dev/null
+++ b/alsaequal.patch
@@ -0,0 +1,13 @@
+--- Makefile 2009-08-27 18:09:24.000000000 -0400
++++ Makefile 2009-08-27 18:09:49.000000000 -0400
+@@ -45,8 +45,8 @@
+
+ install: all
+ @echo Installing...
+- $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
+- $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
++ $(Q)install -m 755 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
++ $(Q)install -m 755 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
+
+ uninstall:
+ @echo Un-installing...
diff --git a/false_error.patch b/false_error.patch
new file mode 100644
index 000000000000..a3221138dcea
--- /dev/null
+++ b/false_error.patch
@@ -0,0 +1,13 @@
+--- ctl_eqaul.c 2013-02-06 22:09:11.000000000 +0100
++++ ctl_equal.c 2013-02-06 22:10:02.000000000 +0100
+@@ -263,8 +263,8 @@
+ for(i = 0; i < equal->num_input_controls; i++) {
+ if(equal->control_data->control[i].type == LADSPA_CNTRL_INPUT) {
+ index = equal->control_data->control[i].index;
+- if(equal->klass->PortDescriptors[index] !=
+- (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL)) {
++ if(equal->klass->PortDescriptors[index] &
++ (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL) == 0) {
+ SNDERR("Problem with control file %s, %d.", controls, index);
+ return -1;
+ }
diff --git a/fix-lib32-makefile.patch b/fix-lib32-makefile.patch
new file mode 100644
index 000000000000..40b978febe70
--- /dev/null
+++ b/fix-lib32-makefile.patch
@@ -0,0 +1,59 @@
+diff --git a/Makefile b/Makefile
+index 57fe2fa..b6a0242 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,10 +4,10 @@ Q ?= @
+ #Q ?=
+
+ # Build Tools
+-CC := gcc
++CC := gcc -m32
+ CFLAGS := -I. -O2 -Wall -funroll-loops -ffast-math -fPIC -DPIC
+-LD := gcc
+-LDFLAGS := -O2 -Wall -shared -lasound
++LD := gcc -m32
++LDFLAGS := -O2 -Wall -shared -lasound -L/usr/lib32
+
+ SND_PCM_OBJECTS = pcm_equal.o ladspa_utils.o
+ SND_PCM_LIBS =
+@@ -45,8 +45,8 @@ clean:
+
+ install: all
+ @echo Installing...
+- $(Q)install -m 755 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
+- $(Q)install -m 755 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
++ $(Q)install -m 755 $(SND_PCM_BIN) ${DESTDIR}/usr/lib32/alsa-lib/
++ $(Q)install -m 755 $(SND_CTL_BIN) ${DESTDIR}/usr/lib32/alsa-lib/
+
+ uninstall:
+ @echo Un-installing...
+diff --git a/ctl_equal.c b/ctl_equal.c
+index 40747d4..e0f1e15 100644
+--- a/ctl_equal.c
++++ b/ctl_equal.c
+@@ -165,8 +165,8 @@ SND_CTL_PLUGIN_DEFINE_FUNC(equal)
+ failure */
+ snd_config_iterator_t it, next;
+ snd_ctl_equal_t *equal;
+- const char *controls = ".alsaequal.bin";
+- const char *library = "/usr/lib/ladspa/caps.so";
++ const char *controls = ".alsaequal.bin32";
++ const char *library = "/usr/lib32/ladspa/caps.so";
+ const char *module = "Eq";
+ long channels = 2;
+ const char *sufix = " Playback Volume";
+diff --git a/pcm_equal.c b/pcm_equal.c
+index 2bc87fb..e4ca02b 100644
+--- a/pcm_equal.c
++++ b/pcm_equal.c
+@@ -149,8 +149,8 @@ SND_PCM_PLUGIN_DEFINE_FUNC(equal)
+ snd_config_iterator_t i, next;
+ snd_pcm_equal_t *equal;
+ snd_config_t *sconf = NULL;
+- const char *controls = ".alsaequal.bin";
+- const char *library = "/usr/lib/ladspa/caps.so";
++ const char *controls = ".alsaequal.bin32";
++ const char *library = "/usr/lib32/ladspa/caps.so";
+ const char *module = "Eq";
+ long channels = 2;
+ int err;
diff --git a/lib32-alsaequal_caps_9.x.patch b/lib32-alsaequal_caps_9.x.patch
new file mode 100644
index 000000000000..4de4c794a057
--- /dev/null
+++ b/lib32-alsaequal_caps_9.x.patch
@@ -0,0 +1,22 @@
+--- ctl_equal.c 2014-02-19 09:36:18.225706000 +0700
++++ ctl_equal.c 2014-02-19 09:38:46.492376869 +0700
+@@ -167,7 +167,7 @@
+ snd_ctl_equal_t *equal;
+ const char *controls = ".alsaequal.bin32";
+ const char *library = "/usr/lib32/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ const char *sufix = " Playback Volume";
+ int err, i, index;
+--- pcm_equal.c 2014-02-19 09:36:18.225706000 +0700
++++ pcm_equal.c 2014-02-19 09:39:05.092377281 +0700
+@@ -151,7 +151,7 @@
+ snd_config_t *sconf = NULL;
+ const char *controls = ".alsaequal.bin32";
+ const char *library = "/usr/lib32/ladspa/caps.so";
+- const char *module = "Eq";
++ const char *module = "Eq10";
+ long channels = 2;
+ int err;
+