summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2018-03-27 00:58:58 +0200
committerfenuks2018-03-27 00:58:58 +0200
commit0143e017946f58fbbcd8e5b139cfb42feb270d2d (patch)
tree103f4f9e638ae5a3adafea4fe289793556d9b2e7
parent26176eb6dc2f252e00d08ca5cc9fdb9d90bb240c (diff)
downloadaur-0143e017946f58fbbcd8e5b139cfb42feb270d2d.tar.gz
Update to 0.17.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 201f11742028..c186c660876d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 23 10:07:38 UTC 2018
+# Mon Mar 26 22:58:13 UTC 2018
pkgbase = python-language-server
pkgdesc = An implementation of the Language Server Protocol for Python
- pkgver = 0.16.0
+ pkgver = 0.17.0
pkgrel = 1
url = https://github.com/palantir/python-language-server
arch = any
@@ -21,9 +21,9 @@ pkgbase = python-language-server
depends = pydocstyle
conflicts = python-language-server
conflicts = python-language-server-git
- source = https://github.com/palantir/python-language-server/archive/0.16.0.tar.gz
- md5sums = ab24b76ef9ab7c9fa307a09b12855269
- sha256sums = e0ff928c6d1baae36856789f5fda44f1642ecf7d3faa505ca45e56ffe729a674
+ source = https://github.com/palantir/python-language-server/archive/0.17.0.tar.gz
+ md5sums = 8b42822343b2b685bfad9a3fcd8c899e
+ sha256sums = 3d8c1c2073ec697b2c87eb50e8abc7dea93b65e71b2a74440e3ad4234d92b29c
pkgname = python-language-server
diff --git a/PKGBUILD b/PKGBUILD
index 761e4f36722b..a51f7e0f8f75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: fenuks
pkgname=python-language-server
-pkgver=0.16.0
+pkgver=0.17.0
pkgrel=1
pkgdesc="An implementation of the Language Server Protocol for Python"
arch=("any")
@@ -14,13 +14,11 @@ makedepends=("python-setuptools")
conflicts=("${pkgname}" "${pkgname}-git")
# install=$pkgname.install
source=("https://github.com/palantir/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('ab24b76ef9ab7c9fa307a09b12855269')
-sha256sums=('e0ff928c6d1baae36856789f5fda44f1642ecf7d3faa505ca45e56ffe729a674')
+md5sums=('8b42822343b2b685bfad9a3fcd8c899e')
+sha256sums=('3d8c1c2073ec697b2c87eb50e8abc7dea93b65e71b2a74440e3ad4234d92b29c')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # remove buildin configparser from requirements or generated entrypoint will fail to find it's distribution
- sed -i "s/'configparser',//g" setup.py
python setup.py build
}