summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit0147790973bdf95adbd0eb12f2e62a945e393325 (patch)
tree499a67b4dfc1c5158d65416fb8c330d1ae4d4fde
downloadaur-0147790973bdf95adbd0eb12f2e62a945e393325.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO27
-rw-r--r--01-without-werror.patch12
-rw-r--r--02-fix-eyed3-args.patch20
-rw-r--r--03-ogg-support.patch46
-rw-r--r--04-oggcomments-overwrite-policy.patch38
-rw-r--r--PKGBUILD42
6 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f195b0940065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mixramp
+ pkgdesc = A utility to analyse sound files and print out the volume profile of the start and end. The idea is to embed those profiles in metadata so players can do intelligent mixing between tracks. Supports FLAC, OGG and MP3.
+ pkgver = 1.3
+ pkgrel = 4
+ url = http://sourceforge.net/projects/mixramp/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = audiofile
+ optdepends = python2-eyed3: writer for mp3 tags
+ optdepends = mpg123: mp3 decoder, needed to perform mixramp analysis
+ optdepends = flac: decoder and writer for flac tags
+ optdepends = vorbis-tools: decoder and writer for ogg/vorbis tags
+ optdepends = mpd: player which support mixramp tags
+ source = mixramp-1.3.tar.gz::http://sourceforge.net/projects/mixramp/files/mixramp_1.3.tgz/download
+ source = 01-without-werror.patch
+ source = 02-fix-eyed3-args.patch
+ source = 03-ogg-support.patch
+ source = 04-oggcomments-overwrite-policy.patch
+ sha256sums = 6d01a0ce0907a7fd225840a21d39144a113b551d176439964bdb5351aecf724c
+ sha256sums = 9f6e34a9c7a59e9723a2d003c5008670e89f73aef8494849e6ec5a729882abf8
+ sha256sums = cc939c0bc1bacf7f1716a1fec972d3f8fbc316e0d891dc61cc4e5e86279e2942
+ sha256sums = ac3200d3915052bc2962758d44f2578e08459000a2b4af3177a779e1e8582a12
+ sha256sums = 059d700a6e11cf9becc4cfce4286c0182bccc84b03afd6434195d2b4f6b45079
+
+pkgname = mixramp
+
diff --git a/01-without-werror.patch b/01-without-werror.patch
new file mode 100644
index 000000000000..5dd7846e7a0f
--- /dev/null
+++ b/01-without-werror.patch
@@ -0,0 +1,12 @@
+(c) 3ED <krzysztof1987@gmail.com>
+Description: Do not treat warnings as errors...
+
+--- Makefile.orig 2014-02-23 20:27:30.000000000 +0000
++++ Makefile 2014-02-23 20:08:52.000000000 +0000
+@@ -1,5 +1,5 @@
+ CC = gcc
+-CFLAGS = -std=c99 -Wall -Wextra -Werror -g -O
++CFLAGS = -std=c99 -Wall -Wextra -g -O
+ INCLUDES =
+ LIBS = -laudiofile -lm
+ SRCS = mixramp.c gain_analysis.c
diff --git a/02-fix-eyed3-args.patch b/02-fix-eyed3-args.patch
new file mode 100644
index 000000000000..8837509d00d6
--- /dev/null
+++ b/02-fix-eyed3-args.patch
@@ -0,0 +1,20 @@
+(c) 3ED <krzysztof1987@gmail.com>
+Description: Upgrade to use latest eyed3...
+
+--- mixramp-tag.orig 2010-04-20 14:46:27.000000000 +0000
++++ mixramp-tag 2014-02-24 14:00:15.000000000 +0000
+@@ -117,10 +117,10 @@
+ ;;
+ (mp3)
+ "$TAGGER" \
+- --set-encoding=utf8 \
+- --set-user-text-frame=mixramp_start:"$MIXRAMP_START" \
+- --set-user-text-frame=mixramp_end:"$MIXRAMP_END" \
+- --set-user-text-frame=mixramp_ref:"$MIXRAMP_REF" \
++ --encoding=utf8 \
++ --user-text-frame=mixramp_start:"$MIXRAMP_START" \
++ --user-text-frame=mixramp_end:"$MIXRAMP_END" \
++ --user-text-frame=mixramp_ref:"$MIXRAMP_REF" \
+ "$FILE" > /dev/null || exit 14
+ ;;
+ esac
diff --git a/03-ogg-support.patch b/03-ogg-support.patch
new file mode 100644
index 000000000000..9e22fc97e58f
--- /dev/null
+++ b/03-ogg-support.patch
@@ -0,0 +1,46 @@
+(c) sekret <aur.archlinux.org>
+Description: Add ogg support...
+
+--- mixramp-tag.orig 2014-02-25 09:13:31.000000000 +0000
++++ mixramp-tag 2014-02-25 09:14:24.000000000 +0000
+@@ -1,12 +1,12 @@
+ #!/bin/sh
+ # A script to add mixramp tags for audio files that support metadata.
+-# Currently supports FLAC.
++# Currently supports FLAC, OGG and MP3
+ NAME="${0##*/}"
+ ANALYZER="${NAME%%-tag}"
+
+ usage() {
+ echo "usage: $NAME <audio_file> ..."
+- echo "<audio_file>s should end in .flac or .mp3"
++ echo "<audio_file>s should end in .flac, .ogg or .mp3"
+ }
+
+ # Check args.
+@@ -31,6 +31,11 @@
+ DUMPER=mpg123
+ DUMPFLAGS="--quiet --wav -"
+ ;;
++ (ogg)
++ TAGGER=vorbiscomment
++ DUMPER=oggdec
++ DUMPFLAGS="--quiet -o -"
++ ;;
+ (*)
+ echo "$NAME: file type of $FILE not recognized."
+ usage
+@@ -123,6 +128,13 @@
+ --user-text-frame=mixramp_ref:"$MIXRAMP_REF" \
+ "$FILE" > /dev/null || exit 14
+ ;;
++ (ogg)
++ "$TAGGER" \
++ --tag "MIXRAMP_START=$MIXRAMP_START" \
++ --tag "MIXRAMP_END=$MIXRAMP_END" \
++ --tag "MIXRAMP_REF=$MIXRAMP_REF" \
++ -a "$FILE" || exit 14
++ ;;
+ esac
+
+ done
diff --git a/04-oggcomments-overwrite-policy.patch b/04-oggcomments-overwrite-policy.patch
new file mode 100644
index 000000000000..416071328e59
--- /dev/null
+++ b/04-oggcomments-overwrite-policy.patch
@@ -0,0 +1,38 @@
+(c) 3ED <krzysztof1987@gmail.com>
+Description: Don't append but replace mixramp tags...
+
+--- mixramp-tag.orig 2014-02-25 09:14:24.000000000 +0000
++++ mixramp-tag 2014-02-25 09:18:04.000000000 +0000
+@@ -129,12 +129,26 @@
+ "$FILE" > /dev/null || exit 14
+ ;;
+ (ogg)
+- "$TAGGER" \
+- --tag "MIXRAMP_START=$MIXRAMP_START" \
+- --tag "MIXRAMP_END=$MIXRAMP_END" \
+- --tag "MIXRAMP_REF=$MIXRAMP_REF" \
+- -a "$FILE" || exit 14
+- ;;
++ OGGTAGS=$(mktemp) || exit 14
++
++ #dump tags to file
++ "$TAGGER" -c "$OGGTAGS" "$FILE" || exit 14
++
++ #remove old mixramp tags
++ sed '/^MIXRAMP_\(START\|END\|REF\)=.*$/d' -i "$OGGTAGS"
++
++ #add new mixramp tags
++ cat >> "$OGGTAGS" <<EOF
++MIXRAMP_START=$MIXRAMP_START
++MIXRAMP_END=$MIXRAMP_END
++MIXRAMP_REF=$MIXRAMP_REF
++EOF
++
++ #overwrite ogg tags
++ "$TAGGER" -c "$OGGTAGS" -w "$FILE" || exit 14
++
++ rm -f "$OGGTAGS"
++ ;;
+ esac
+
+ done
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af72db215b59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Mantainer: 3ED <krzysztof1987@gmail.com>
+
+pkgname=mixramp
+pkgver=1.3
+pkgrel=4
+pkgdesc="A utility to analyse sound files and print out the volume profile of the start and end. The idea is to embed those profiles in metadata so players can do intelligent mixing between tracks. Supports FLAC, OGG and MP3."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/mixramp/"
+license=('GPL')
+depends=('audiofile')
+optdepends=('python2-eyed3: writer for mp3 tags'
+ 'mpg123: mp3 decoder, needed to perform mixramp analysis'
+ 'flac: decoder and writer for flac tags'
+ 'vorbis-tools: decoder and writer for ogg/vorbis tags'
+ 'mpd: player which support mixramp tags')
+source=("${pkgname}-${pkgver}.tar.gz::http://sourceforge.net/projects/${pkgname}/files/${pkgname}_${pkgver}.tgz/download"
+ "01-without-werror.patch"
+ "02-fix-eyed3-args.patch"
+ "03-ogg-support.patch"
+ "04-oggcomments-overwrite-policy.patch")
+sha256sums=('6d01a0ce0907a7fd225840a21d39144a113b551d176439964bdb5351aecf724c'
+ '9f6e34a9c7a59e9723a2d003c5008670e89f73aef8494849e6ec5a729882abf8'
+ 'cc939c0bc1bacf7f1716a1fec972d3f8fbc316e0d891dc61cc4e5e86279e2942'
+ 'ac3200d3915052bc2962758d44f2578e08459000a2b4af3177a779e1e8582a12'
+ '059d700a6e11cf9becc4cfce4286c0182bccc84b03afd6434195d2b4f6b45079')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p0 -i "$srcdir"/01-without-werror.patch
+ patch -p0 -i "$srcdir"/02-fix-eyed3-args.patch
+ patch -p0 -i "$srcdir"/03-ogg-support.patch
+ patch -p0 -i "$srcdir"/04-oggcomments-overwrite-policy.patch
+}
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+package() {
+ cd "$srcdir/$pkgname"
+ install -dm755 "$pkgdir"/usr/bin/
+ install -m755 mixramp mixramp-tag "$pkgdir"/usr/bin/
+}