summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2018-10-07 13:00:47 +0200
committerJulian Xhokaxhiu2018-10-07 13:00:47 +0200
commit016063399f8a3ca7b5f1e42c57a21af5404b5fd1 (patch)
treee7be3328373d091a82717e6d412a0499df3a6329
parent61eb1614f55faf01ba980aacafc726fda5f8c7a9 (diff)
downloadaur-016063399f8a3ca7b5f1e42c57a21af5404b5fd1.tar.gz
1.5.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e13a3c7ad6b..ac52405e65a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = getmu
pkgdesc = A full-stack DevOps on AWS framework
- pkgver = 1.4.6
+ pkgver = 1.5.5
pkgrel = 1
url = https://github.com/stelligent/mu
+ arch = i686
arch = x86_64
license = MIT
- source = https://github.com/stelligent/mu/releases/download/v1.4.6/mu-linux-amd64
- md5sums = e3cbc51552e5a238c5436e235a3cbec1
+ source_i686 = https://github.com/stelligent/mu/releases/download/v1.5.5/mu-linux-386
+ md5sums_i686 = 6f693bc8139ee4d60adaada39bf6f689
+ source_x86_64 = https://github.com/stelligent/mu/releases/download/v1.5.5/mu-linux-amd64
+ md5sums_x86_64 = 8320d0675ff3f00249a47b18146de926
pkgname = getmu
diff --git a/PKGBUILD b/PKGBUILD
index cfa10f8462b9..860f897d55fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,28 @@
#Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
pkgname=getmu
-pkgver=1.4.6
+pkgver=1.5.5
pkgrel=1
pkgdesc="A full-stack DevOps on AWS framework"
-arch=('x86_64')
-source=("https://github.com/stelligent/mu/releases/download/v$pkgver/mu-linux-amd64")
+arch=('i686' 'x86_64')
+source_i686=("https://github.com/stelligent/mu/releases/download/v$pkgver/mu-linux-386")
+source_x86_64=("https://github.com/stelligent/mu/releases/download/v$pkgver/mu-linux-amd64")
url="https://github.com/stelligent/mu"
license=("MIT")
-md5sums=("e3cbc51552e5a238c5436e235a3cbec1")
+md5sums_i686=("6f693bc8139ee4d60adaada39bf6f689")
+md5sums_x86_64=("8320d0675ff3f00249a47b18146de926")
package() {
+ _ARCH=""
+
+ # Update the architecture name based on the current one running this PKGBUILD
+ if [ "$CARCH" == "i686" ]; then
+ _ARCH="386"
+ elif [ "$CARCH" == "x86_64" ]; then
+ _ARCH="amd64"
+ fi
+
cd "$srcdir"
- chmod +x "mu-linux-amd64"
- install -Dm755 "mu-linux-amd64" "$pkgdir/usr/bin/mu"
+ chmod +x "mu-linux-$_ARCH"
+ install -Dm755 "mu-linux-$_ARCH" "$pkgdir/usr/bin/mu"
}