summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVale Cofer-Shabica2017-09-25 11:49:22 -0400
committerVale Cofer-Shabica2017-09-25 11:49:22 -0400
commit0171673278edb95add48026e80603e551324c9c6 (patch)
tree0ec393dbd4d62e2d6343e8bab37e92efd529e543
parent8172a37ab1640f59e035f6c48c4ffcb528e0cc5d (diff)
downloadaur-0171673278edb95add48026e80603e551324c9c6.tar.gz
simplified install and map update
-rw-r--r--PKGBUILD17
-rw-r--r--urw-classico.install45
2 files changed, 18 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd8b19b43aed..ec91acf089c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
+# Contributor: Vale Cofer-Shabica <vale.cofershabica@gmail.com>
pkgname=urw-classico
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='URW Classico font from CTAN (for texlive)'
arch=('any')
license=('CUSTOM:alladin')
url='http://www.ctan.org/pkg/urw-classico'
depends=('texlive-core')
install=$pkgname.install
-source=('http://mirror.ctan.org/fonts/urw/classico.zip'
+source=('http://mirrors.ctan.org/install/fonts/urw/classico.tds.zip'
'license')
-md5sums=('e8ce4a2c293ffe386bf5800e0f9f89df'
- '330cccd8a2978150e99c5e20926af5f3')
+noextract=('classico.tds.zip')
+md5sums=('166eb8e7f2e1ca764b02e00aae5e86fb'
+ '7689a58e80bcc8546b76e397b83a572b')
package() {
cd "$srcdir"
- texmf_root=usr/share/texmf/tex/latex
- mkdir -p "$pkgdir/$texmf_root/classico"
- cp -r classico "$pkgdir/$texmf_root"
+ texmf_root=usr/share/texmf
+ mkdir -p "$pkgdir/$texmf_root"
+ bsdtar -xf $srcdir/classico.tds.zip -C "$pkgdir/$texmf_root"
+ chown -R 0:0 $pkgdir/$texmf_root
install -Dm644 $srcdir/license "$pkgdir/usr/share/licenses/$pkgname/license"
}
diff --git a/urw-classico.install b/urw-classico.install
index e760e71dbcca..0b49e142cbb2 100644
--- a/urw-classico.install
+++ b/urw-classico.install
@@ -1,53 +1,24 @@
-PKGNAME="urw-classico"
-UPDMAP="etc/texmf/web2c/updmap.cfg"
-UPDMAPLOCAL="etc/texmf/web2c/updmap-local.cfg"
-SYNCWITHTREES=''
-
-MAPFILE="var/lib/texmf/arch/installedpkgs/$PKGNAME.maps"
+TEXMFLOCAL="/usr/share/texmf"
+UPDMAP="fonts/map/dvips/classico/"
+MAP="classico.map"
post_install() {
- TMPFILE=`mktemp`
- echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
- cp "$UPDMAP" "$TMPFILE"
- echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
- echo " into /etc/texmf/web2c/updmap-local.cfg"
- cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
- cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
- [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
echo ">>> texlive: updating the filename database..."
- usr/bin/mktexlsr
+ mktexlsr
echo ">>> texlive: updating the fontmap files with updmap..."
- usr/bin/updmap-sys --quiet --nohash
+ cd $TEXMFLOCAL/$UPDMAP
+ updmap-sys --quiet --enable Map=$MAP
echo " done."
}
post_upgrade() {
- #TMPFILE=`mktemp`
- #echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
- #cp "$UPDMAP" "$TMPFILE"
- #echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
- #echo " into /etc/texmf/web2c/updmap-local.cfg"
- #cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
- #cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
- #[ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
- #echo ">>> texlive: updating the filename database..."
- #usr/bin/mktexlsr
- #echo ">>> texlive: updating the fontmap files with updmap..."
- #usr/bin/updmap-sys --quiet --nohash $SYNCWITHTREES
- #echo " done."
post_install
}
-pre_remove() {
-for m in `cut -d' ' -f2 $MAPFILE`; do
- sed -i "/\s$m/d" $UPDMAP ;
-done
-}
-
post_remove() {
echo ">>> texlive: updating the filename database..."
- usr/bin/mktexlsr
+ mktexlsr
echo ">>> texlive: updating the fontmap files with updmap..."
- usr/bin/updmap-sys --quiet --nohash
+ updmap-sys --quiet
echo " done."
}