summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-06-13 17:29:50 +0200
committerbartus2020-06-16 17:56:41 +0200
commit01a98ed539b333e3deabf9a546e4bed65317a702 (patch)
tree7d04147f9232ea3fcf9c9a2e6a1ead04eb2a29a9
parent14610844b1308f01ce0695247ae351a980146073 (diff)
downloadaur-01a98ed539b333e3deabf9a546e4bed65317a702.tar.gz
extract libxml from extren C directive
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--libxml.patch66
3 files changed, 75 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e23b52d2509..77a35c5a863c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -51,12 +51,14 @@ pkgbase = scilab
source = scilab-LD_LIBRARY_PATH.patch
source = scilab-0004-Fix-build-with-ocaml-4.0.4.patch
source = scilab-num.patch
+ source = libxml.patch
sha256sums = ae6befb0153fb823fd647f4eb36076f98fd20fed601f7dfa94d8c13e31044964
sha256sums = 7b7b5609ee36b6f8d801eeb3899cd62cc889c2038e0e1616b7640f9b8a0424b0
sha256sums = 38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd
sha256sums = a39277cb8cfc3d7929c73ce6d707dc24e3df4b8d8f2d587f075efebda79ff4db
sha256sums = 6712c6db2f3ba365d150e1feb1c71bf691f8aa3b45d5a872b05a42f0daf23392
sha256sums = 31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed
+ sha256sums = c04114c4ef63d76bf898808e90c892de093fcc400a2371c7aa287b76c0c5d041
pkgname = scilab
diff --git a/PKGBUILD b/PKGBUILD
index 2589f411226a..c6dcbca3264f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,13 +29,16 @@ source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-strict-jar.patch"
"${pkgname}-LD_LIBRARY_PATH.patch"
"${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch"
- "${pkgname}-num.patch")
+ "${pkgname}-num.patch"
+ "libxml.patch"
+ )
sha256sums=('ae6befb0153fb823fd647f4eb36076f98fd20fed601f7dfa94d8c13e31044964'
'7b7b5609ee36b6f8d801eeb3899cd62cc889c2038e0e1616b7640f9b8a0424b0'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
'a39277cb8cfc3d7929c73ce6d707dc24e3df4b8d8f2d587f075efebda79ff4db'
'6712c6db2f3ba365d150e1feb1c71bf691f8aa3b45d5a872b05a42f0daf23392'
- '31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed')
+ '31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed'
+ 'c04114c4ef63d76bf898808e90c892de093fcc400a2371c7aa287b76c0c5d041')
prepare(){
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -50,6 +53,8 @@ prepare(){
# OCaml
patch -p0 < "${srcdir}"/${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch
patch -p0 < "${srcdir}"/${pkgname}-num.patch
+ # libxml
+ patch -p1 < "${srcdir}"/libxml.patch
}
build() {
diff --git a/libxml.patch b/libxml.patch
new file mode 100644
index 000000000000..55d2e744a2e8
--- /dev/null
+++ b/libxml.patch
@@ -0,0 +1,66 @@
+--- orig/scilab-6.1.0/modules/functions_manager/src/cpp/dynamic_modules.cpp 2020-02-25 10:59:51.000000000 +0100
++++ scilab-6.1.0/modules/functions_manager/src/cpp/dynamic_modules.cpp 2020-06-13 17:52:19.258491176 +0200
+@@ -22,13 +22,13 @@
+ {
+ #include "loadOnUseClassPath.h"
+ #include "Scierror.h"
++}
+
+ //XML API
+ #include <libxml/xpath.h>
+ #include <libxml/xmlreader.h>
+ #include "sci_malloc.h"
+ #include "configvariable_interface.h"
+-}
+
+ vectGateway loadGatewaysName(const std::wstring& _wstModuleName)
+ {
+--- orig/scilab-6.1.0/modules/io/src/cpp/loadlib.cpp 2020-02-25 10:59:59.000000000 +0100
++++ scilab-6.1.0/modules/io/src/cpp/loadlib.cpp 2020-06-13 17:38:17.474133786 +0200
+@@ -17,6 +17,8 @@
+ #include "context.hxx"
+ #include "loadlib.hxx"
+ #include "macrofile.hxx"
++#include <libxml/xpath.h>
++#include <libxml/xmlreader.h>
+ extern "C"
+ {
+ #include "FileExist.h"
+@@ -26,8 +28,6 @@
+ #include "fullpath.h"
+ #include "PATH_MAX.h"
+ #include "pathconvert.h"
+-#include <libxml/xpath.h>
+-#include <libxml/xmlreader.h>
+ }
+
+ #define DEFAULT_ENCODING "UTF-8"
+--- orig/scilab-6.1.0/modules/xml/src/cpp/XMLDocument.hxx 2020-02-25 11:00:18.000000000 +0100
++++ scilab-6.1.0/modules/xml/src/cpp/XMLDocument.hxx 2020-06-13 17:45:02.443795087 +0200
+@@ -23,13 +23,10 @@
+
+ #include "dynlib_xml_scilab.h"
+
+-extern "C"
+-{
+ #include "xml.h"
+ #ifndef XML_XPATH_CHECKNS
+ #define XML_XPATH_CHECKNS
+ #endif
+-}
+
+ #include "XMLObject.hxx"
+
+--- orig/scilab-6.1.0/modules/scicos/includes/XMIResource.hxx 2020-02-25 11:00:08.000000000 +0100
++++ scilab-6.1.0/modules/scicos/includes/XMIResource.hxx 2020-06-13 18:13:54.985717732 +0200
+@@ -22,10 +22,8 @@
+ #include <string>
+ #include <vector>
+
+-extern "C" {
+ #include <libxml/xmlwriter.h>
+ #include <libxml/xmlreader.h>
+-}
+
+ namespace org_scilab_modules_scicos
+ {