summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkaash Suresh2020-04-19 11:32:12 -0500
committerAkaash Suresh2020-04-19 11:32:12 -0500
commit01aaad53ba1b7315e378e95dbcc061c5d641c9ae (patch)
tree79d4d79e2c45b51b4b2d268d25a79a865cc52910
parentb398d96e7b41659a863f2e080b86150a6e0d9a76 (diff)
downloadaur-01aaad53ba1b7315e378e95dbcc061c5d641c9ae.tar.gz
Move to yapf from community, add libffi as dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 959067d7ff1b..7879cce363b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qmk
pkgdesc = CLI tool for customizing supported mechanical keyboards.
pkgver = 0.0.33
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/qmk/qmk_cli
arch = any
license = MIT
@@ -26,9 +26,11 @@ pkgbase = qmk
depends = diffutils
depends = gcc
depends = git
+ depends = libffi
depends = libusb-compat
depends = unzip
depends = wget
+ depends = yapf
depends = zip
source = https://files.pythonhosted.org/packages/source/q/qmk/qmk-0.0.33.tar.gz
sha256sums = 48c0c77929f5e795516beb2c44f851b9083420d7b6e0f76c9d716f827b2fc893
diff --git a/PKGBUILD b/PKGBUILD
index eef07c4d7eb6..866a2dbaa2fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Akaash Suresh <https://github.com/Curry>
pkgname=qmk
pkgver=0.0.33
-pkgrel=1
+pkgrel=2
pkgdesc="CLI tool for customizing supported mechanical keyboards."
arch=('any')
url="https://github.com/qmk/qmk_cli"
@@ -25,9 +25,11 @@ depends=(
'diffutils'
'gcc'
'git'
+ 'libffi'
'libusb-compat'
'unzip'
'wget'
+ 'yapf'
'zip'
)
makedepends=('python-setuptools' 'python' 'python-pip')
@@ -35,7 +37,7 @@ source=("https://files.pythonhosted.org/packages/source/q/qmk/qmk-${pkgver}.tar.
sha256sums=('48c0c77929f5e795516beb2c44f851b9083420d7b6e0f76c9d716f827b2fc893')
build() {
- pip install --no-deps --target="deps" yapf hjson
+ pip install --no-deps --target="deps" hjson
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
}