summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatti Niemenmaa2019-01-04 10:49:38 +0200
committerMatti Niemenmaa2019-01-04 17:33:06 +0200
commit01ba1b9ccd8108f918b74afab776c6b812ef3082 (patch)
tree4f2407d9116927855c7dd2db468acc1e3f2b92b8
downloadaur-01ba1b9ccd8108f918b74afab776c6b812ef3082.tar.gz
Initial commit for 1.0.1, seems to work
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22eb7451b8f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = git-deps
+ pkgdesc = git commit dependency analysis tool
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/aspiers/git-deps
+ arch = any
+ license = GPL2
+ depends = git
+ depends = python
+ depends = python-flask
+ depends = python-pygit2
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/g/git-deps/git-deps-1.0.1.tar.gz
+ sha512sums = e298304442184362cf4bb2216314c1d4bbdb9a69a3197b32b6a7d62ba630a73f60e531b5e2c0ad169885cab2fbecabe3a20cc5cdfba505570bc76bf3b997ef1b
+
+pkgname = git-deps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7394078e0e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=git-deps
+depends=(git python python-flask python-pygit2 python-setuptools)
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='git commit dependency analysis tool'
+arch=(any)
+url=https://github.com/aspiers/git-deps
+license=(GPL2)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz)
+sha512sums=('e298304442184362cf4bb2216314c1d4bbdb9a69a3197b32b6a7d62ba630a73f60e531b5e2c0ad169885cab2fbecabe3a20cc5cdfba505570bc76bf3b997ef1b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
+
+ # The only thing from node_modules that is actually required is d3.min.js, so
+ # nuke the rest.
+ find "$pkgdir" -path '*/node_modules/*' \
+ \( -type f ! -name d3.min.js -delete -o \
+ -type d ! -path '*/node_modules/d3' -exec rmdir {} + \)
+}
+
+# Depends on having the git repo instead of just the source tarball.
+#
+#checkdepends=(python-pytest python-pytest-cov)
+#check() {
+# cd "$srcdir/$pkgname-$pkgver"
+# python setup.py test
+#}