summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmily Maré (emileet)2020-12-31 13:15:40 +1100
committerEmily Maré (emileet)2020-12-31 13:15:40 +1100
commit01c8745ca8ab607b5304a5cc397f7ab2c2050e1b (patch)
treede829abc3a93226d96d14141c8bd9616e4d15341
parent4d0624822e45a570e13fc62cab9fbc080675e5c6 (diff)
downloadaur-01c8745ca8ab607b5304a5cc397f7ab2c2050e1b.tar.gz
remove linux-get-scroll-info.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--linux-get-scroll-info.patch21
3 files changed, 6 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 222555fd65c2..a2b7d7cb71ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = reclass.net-git
pkgdesc = A reverse-engineering tool for dissecting data structures in memory
- pkgver = 1.2.r140.g534b684
- pkgrel = 2
+ pkgver = 1.2.r228.g96b36cf
+ pkgrel = 1
url = https://github.com/ReClassNET/ReClass.NET
arch = x86_64
license = MIT
@@ -12,11 +12,9 @@ pkgbase = reclass.net-git
source = git+https://github.com/ReClassNET/ReClass.NET.git
source = linux-native-plugin-path.patch
source = linux-windows-sections.patch
- source = linux-get-scroll-info.patch
sha256sums = SKIP
sha256sums = 78d3136c874a2c43042cf4685aa8520a25145c09e7118d3c1724df5a10caf613
sha256sums = 66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15
- sha256sums = 894f4caf2a440d193e3c411142d92e956df6db8362709c178a88e791e6399192
pkgname = reclass.net-git
diff --git a/PKGBUILD b/PKGBUILD
index 1670f6def00b..0d651894be4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=reclass.net-git
_pkgname=ReClass.NET
-pkgver=1.2.r140.g534b684
-pkgrel=2
+pkgver=1.2.r228.g96b36cf
+pkgrel=1
pkgdesc="A reverse-engineering tool for dissecting data structures in memory"
arch=('x86_64')
license=('MIT')
@@ -13,12 +13,10 @@ depends=('mono')
makedepends=('git' 'mono-msbuild')
source=("git+https://github.com/ReClassNET/ReClass.NET.git"
"linux-native-plugin-path.patch"
- "linux-windows-sections.patch"
- "linux-get-scroll-info.patch")
+ "linux-windows-sections.patch")
sha256sums=('SKIP'
'78d3136c874a2c43042cf4685aa8520a25145c09e7118d3c1724df5a10caf613'
- '66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15'
- '894f4caf2a440d193e3c411142d92e956df6db8362709c178a88e791e6399192')
+ '66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15')
pkgver() {
cd ${_pkgname}
diff --git a/linux-get-scroll-info.patch b/linux-get-scroll-info.patch
deleted file mode 100644
index c9b5659695f6..000000000000
--- a/linux-get-scroll-info.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/ReClass.NET/UI/ScrollableCustomControl.cs b/ReClass.NET/UI/ScrollableCustomControl.cs
-index 4de6a4d..e5c05b7 100644
---- a/ReClass.NET/UI/ScrollableCustomControl.cs
-+++ b/ReClass.NET/UI/ScrollableCustomControl.cs
-@@ -2,6 +2,7 @@
- using System.Diagnostics.Contracts;
- using System.Runtime.InteropServices;
- using System.Windows.Forms;
-+using ReClassNET.Native;
-
- namespace ReClassNET.UI
- {
-@@ -213,7 +214,7 @@ namespace ReClassNET.UI
- case ScrollEventType.ThumbTrack:
- case ScrollEventType.ThumbPosition:
-
-- if (GetScrollInfo(new HandleRef(this, Handle), bar, scrollinfo))
-+ if (!NativeMethods.IsUnix() && GetScrollInfo(new HandleRef(this, Handle), bar, scrollinfo))
- {
- SetValue(type, scrollProperties, scrollinfo.nTrackPos);
- }