summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-02 19:03:31 +0800
committerzxp198210052023-08-02 19:03:31 +0800
commit01d6e854037ab4e3c8d67101ce5534143d153fe0 (patch)
treea3d8233f3f3bc4bcd881ed3c8c1799420df53d10
parent7ad3be851ece76043930acfd5d5096c544997337 (diff)
downloadaur-01d6e854037ab4e3c8d67101ce5534143d153fe0.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--dbgate.sh6
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8a21babc945..bffee91b82f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.6
- pkgrel = 1
+ pkgrel = 2
url = https://dbgate.org/
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
depends = hicolor-icon-theme
- depends = electron
+ depends = electron25
depends = gcc-libs
depends = glibc
provides = dbgate
@@ -16,7 +16,7 @@ pkgbase = dbgate-bin
source = LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/master/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = 18dbf5f062a88dc30c7cfb432b02e339407b41202f56df7f8f79748132f180dd
+ sha256sums = 530c8f6e9e0e9e3655dfefe281f95e831ae0b2c1c5c6fa2caa16cc7081c23767
source_aarch64 = dbgate-5.2.6-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.6/dbgate-5.2.6-linux_arm64.AppImage
sha256sums_aarch64 = 31f496aba3184e978faa6ad845637b9495f097d9cd0b017b8ee7004ed939350c
source_armv7h = dbgate-5.2.6-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.6/dbgate-5.2.6-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 0c5e13ebe162..59455edbc011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="dbgate-bin"
pkgver=5.2.6
-pkgrel=1
+pkgrel=2
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
arch=('aarch64' 'armv7h' 'x86_64')
url="https://dbgate.org/"
@@ -10,23 +10,21 @@ _githuburl="https://github.com/dbgate/dbgate"
license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}")
-depends=('hicolor-icon-theme' 'electron' 'gcc-libs' 'glibc')
+depends=('hicolor-icon-theme' 'electron25' 'gcc-libs' 'glibc')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_arm64.AppImage")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_x86_64.AppImage")
source=("LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/master/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- '18dbf5f062a88dc30c7cfb432b02e339407b41202f56df7f8f79748132f180dd')
+ '530c8f6e9e0e9e3655dfefe281f95e831ae0b2c1c5c6fa2caa16cc7081c23767')
sha256sums_aarch64=('31f496aba3184e978faa6ad845637b9495f097d9cd0b017b8ee7004ed939350c')
sha256sums_armv7h=('1729dbb58eb4cbe28d55b97b8a5486c95a5ec9baf3b703cfab450e669cbe957c')
sha256sums_x86_64=('070e7e31a617b8e4f50f9cf7708993a12e8075dfed0f0cbdaff6fb32cbe2c941')
-
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
}
-
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
diff --git a/dbgate.sh b/dbgate.sh
index ad2deb907c65..0a808e38f21e 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron25
+_ASAR="/opt/dbgate/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /opt/dbgate/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron --no-sandbox /opt/dbgate/app.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file