summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrr-2016-03-17 14:19:32 +0100
committerrr-2016-03-17 14:19:32 +0100
commit01df6496e3059914123b445c16f6afc552ba5ffa (patch)
treea7091fd4e0ea4b5d0a308be7f237c12cb0a838d9
downloadaur-01df6496e3059914123b445c16f6afc552ba5ffa.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..567a5b535929
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = shot-git
+ pkgdesc = A minimal screenshot tool aiming to provide good control over screenshot region.
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/rr-/shot
+ arch = any
+ license = GPL
+ depends = git
+ depends = gcc
+ depends = xorg-xrandr
+ depends = python
+ depends = wget
+ source = shot-git::git://github.com/rr-/shot.git
+ sha256sums = SKIP
+
+pkgname = shot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25bd233200d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Author: rr- <rr-@sakuya.pl>
+# Maintainer: rr- <rr-@sakuya.pl>
+pkgname=shot-git
+pkgver=2.1
+pkgrel=1
+pkgdesc='A minimal screenshot tool aiming to provide good control over screenshot region.'
+arch=('any')
+url='https://github.com/rr-/shot'
+license=('GPL')
+depends=('git' 'gcc' 'xorg-xrandr' 'python' 'wget')
+source=("$pkgname::git://github.com/rr-/shot.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --abbrev=0
+}
+
+build() {
+ cd "$pkgname"
+ ./bootstrap
+ ./waf configure
+ ./waf
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 build/shot "$pkgdir/usr/bin/shot"
+ install -Dm644 docs/shot.1 "$pkgdir/usr/share/man/man1/shot.1p"
+}