aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkXuan2021-08-17 20:44:01 +0800
committerkXuan2021-08-17 20:48:07 +0800
commit01e667fac6adb9cd3d70add8bcdac410d76c753f (patch)
tree40717a5dc4a182d9bc6974ad5e2f5136c78461f1
parent0be3bfc0b05457fb7d96f165ca997ee083010b09 (diff)
downloadaur-01e667fac6adb9cd3d70add8bcdac410d76c753f.tar.gz
remove out-date dependencies
The library files packed in the .deb is made before 2019. These libraries are not compatible with arch linux. Some features are failed due to this reason. Such as unable using fcitx in the main program. This patch remove all libraries. So the netease main program can use libraries in the system. Signed-off-by: kXuan <kxuanobj@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rwxr-xr-xnetease-cloud-music.bash3
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c5c73e5aff0..e57659af4cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = netease-cloud-music
pkgdesc = Netease Cloud Music, converted from .deb package
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://music.163.com/
arch = x86_64
license = custom
+ depends = qcef
+ depends = vlc
source = https://d1.music.126.net/dmusic/netease-cloud-music_1.2.1_amd64_ubuntu_20190428.deb
source = https://music.163.com/html/web2/service.html
+ source = netease-cloud-music.bash
md5sums = 1f47c7dc3d9ce46da8099e539ee8a74d
md5sums = ee09cacb054f6a346bf935737df3f33d
+ md5sums = SKIP
pkgname = netease-cloud-music
diff --git a/PKGBUILD b/PKGBUILD
index d69115589149..8a55733f2a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,29 @@
pkgname=netease-cloud-music
pkgver=1.2.1
_pkgdate=20190428
-pkgrel=2
+pkgrel=3
pkgdesc="Netease Cloud Music, converted from .deb package"
arch=("x86_64")
url="https://music.163.com/"
license=('custom')
-depends=()
+depends=('qcef' 'vlc')
source=(
"https://d1.music.126.net/dmusic/netease-cloud-music_${pkgver}_amd64_ubuntu_${_pkgdate}.deb"
"https://music.163.com/html/web2/service.html"
+ "netease-cloud-music.bash"
)
md5sums=('1f47c7dc3d9ce46da8099e539ee8a74d'
- 'ee09cacb054f6a346bf935737df3f33d')
+ 'ee09cacb054f6a346bf935737df3f33d'
+ 'SKIP')
DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
package() {
cd ${srcdir}
- tar -xvf data.tar.xz -C ${pkgdir}
+ tar -xvf data.tar.xz -C ${pkgdir} \
+ ./opt/netease/netease-cloud-music/netease-cloud-music \
+ ./usr/share \
+ ./usr/bin/netease-cloud-music
install -D -m644 service.html ${pkgdir}/usr/share/licenses/$pkgname/license.html
+ install -D -m755 netease-cloud-music.bash ${pkgdir}/opt/netease/netease-cloud-music/netease-cloud-music.bash
}
diff --git a/netease-cloud-music.bash b/netease-cloud-music.bash
new file mode 100755
index 000000000000..a77f200f61d8
--- /dev/null
+++ b/netease-cloud-music.bash
@@ -0,0 +1,3 @@
+#!/bin/sh
+HERE="$(dirname "$(readlink -f "${0}")")"
+exec "${HERE}"/netease-cloud-music $@