summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManish Munikar2015-12-28 10:34:24 +0545
committerManish Munikar2015-12-28 10:34:24 +0545
commit020135267916b924c92234e1fcccc10b68d2cc54 (patch)
treeecdda0fd03c830c95f284ce47b0a193a5921972c
downloadaur-020135267916b924c92234e1fcccc10b68d2cc54.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rwxr-xr-xargouml4
-rw-r--r--argouml.desktop7
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca2fb6fa3aff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 04:12:26 UTC 2015
+pkgbase = argouml
+ pkgdesc = UML 1.4 modeller
+ pkgver = 0.34
+ pkgrel = 1
+ url = http://argouml.tigris.org/
+ arch = any
+ license = EPL
+ depends = java-runtime
+ source = argouml-0.34.tar.gz::http://argouml-downloads.tigris.org/nonav/argouml-0.34/ArgoUML-0.34.tar.gz
+ source = argouml
+ source = argouml.desktop
+ md5sums = 440efea6096a00b8c19daab1ecddaf7c
+ md5sums = c9febf6fcf3230e1a1538ef9502d2d2c
+ md5sums = 1fb534f8d951e4de781216bcf44fa03c
+
+pkgname = argouml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b34b254be5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Manish Munikar <munikarmanish at gmail dot com>
+
+pkgname=argouml
+pkgver=0.34
+pkgrel=1
+pkgdesc="UML 1.4 modeller"
+arch=('any')
+url="http://argouml.tigris.org/"
+license=('EPL')
+depends=('java-runtime')
+source=("${pkgname}-${pkgver}.tar.gz::http://argouml-downloads.tigris.org/nonav/argouml-0.34/ArgoUML-0.34.tar.gz"
+ "${pkgname}"
+ "${pkgname}.desktop");
+noextract=()
+md5sums=("440efea6096a00b8c19daab1ecddaf7c"
+ "c9febf6fcf3230e1a1538ef9502d2d2c"
+ "1fb534f8d951e4de781216bcf44fa03c")
+validpgpkeys=()
+
+package() {
+ # Creating directories
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ mkdir -p ${pkgdir}/usr/bin/
+ mkdir -p ${pkgdir}/usr/share/applications/
+
+ msg2 "Copying source files..."
+ cp -ar ${srcdir}/${pkgname}-${pkgver}/* ${pkgdir}/opt/${pkgname}/
+
+ msg2 "Creating executable file..."
+ cp -a ${srcdir}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ msg2 "Creating desktop entry..."
+ cp -a ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/argouml b/argouml
new file mode 100755
index 000000000000..ca711adc5c76
--- /dev/null
+++ b/argouml
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+# Launch the program
+/opt/argouml/argouml.sh
diff --git a/argouml.desktop b/argouml.desktop
new file mode 100644
index 000000000000..bc2b34abb39e
--- /dev/null
+++ b/argouml.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=ArgoUML
+Type=Application
+Exec=argouml
+Comment=UML 1.4 modeller
+Categories=Education;Engineering;Development;Programming;Science;
+Icon=/opt/argouml/icon/ArgoIcon256x256.png