summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-07-17 19:48:34 +0200
committerAndré Fettouhi2015-07-17 19:48:34 +0200
commit0212aabd5e30c450649fc47a03f848cc17c30343 (patch)
tree2beb33e94693c06d022bd1bc3a54a15eb909804a
downloadaur-0212aabd5e30c450649fc47a03f848cc17c30343.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--gog-blackwell-legacy4
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2644d48e236
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gog-blackwell-legacy
+ pkgdesc = Meet Rosangela Blackwell, an embittered writer who just found out that she is a medium and that it’s her mission.
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/blackwell_bundle
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = freetype2
+ source = local://gog_blackwell_legacy_1.0.0.1.tar.gz
+ source = gog-blackwell-legacy
+ sha256sums = 819bd16896920db3147409fe5e2ea2cb05112ba11f7e292c39dcf255a1882ebe
+ sha256sums = 85772f6c6b12938561a8ae10ac948ff1fd8f5a6dd36ff907f530f3a495c909a0
+
+pkgname = gog-blackwell-legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abffbed25bec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+
+pkgname=gog-blackwell-legacy
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Meet Rosangela Blackwell, an embittered writer who just found out that she is a medium and that it’s her mission."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/blackwell_bundle"
+license=("custom")
+groups=("games")
+source=("local://gog_blackwell_legacy_${pkgver}.tar.gz" "gog-blackwell-legacy")
+sha256sums=('819bd16896920db3147409fe5e2ea2cb05112ba11f7e292c39dcf255a1882ebe'
+ '85772f6c6b12938561a8ae10ac948ff1fd8f5a6dd36ff907f530f3a495c909a0')
+depends=(freetype2)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/blackwell-legacy
+ cp -r "${srcdir}"/Blackwell\ Legacy/* "${pkgdir}"/opt/gog/blackwell-legacy
+ install -Dm644 "${srcdir}"/Blackwell\ Legacy/support/gog-blackwell-legacy-primary.desktop "${pkgdir}"/usr/share/applications/gog-blackwell-legacy.desktop
+ install -Dm644 "${srcdir}"/Blackwell\ Legacy/support/gog-blackwell-legacy.png "${pkgdir}"/usr/share/pixmaps/gog-blackwell-legacy.png
+ install -Dm644 "${srcdir}"/Blackwell\ Legacy/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-blackwell-legacy" "${pkgdir}/usr/bin/gog-blackwell-legacy"
+}
diff --git a/gog-blackwell-legacy b/gog-blackwell-legacy
new file mode 100644
index 000000000000..75ec48dd2a53
--- /dev/null
+++ b/gog-blackwell-legacy
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/blackwell-legacy"
+
+"$gogdir"/start.sh