summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorExcitable Snowball2019-04-15 23:43:22 -0700
committerExcitable Snowball2019-04-16 00:39:16 -0700
commit024076a62e0e2e18bfc6dc1099e89ab6ff12d9c7 (patch)
tree1c9d7cd8129b362b584d54dcd76e3f8197a84279
parent196db8cca5002f9acec71208433a847006a801e2 (diff)
downloadaur-024076a62e0e2e18bfc6dc1099e89ab6ff12d9c7.tar.gz
Adopt changes from robertfoster
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--webplotdigitizer.desktop11
3 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df50a2e3fb62..8a87c667a56f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Mon Oct 1 10:29:32 UTC 2018
pkgbase = webplotdigitizer-bin
pkgdesc = Tool to extract numerical data from plot images
pkgver = 4.1
@@ -7,9 +5,18 @@ pkgbase = webplotdigitizer-bin
url = https://automeris.io/WebPlotDigitizer/
arch = x86_64
license = AGPL3
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = nss
source = https://automeris.io/downloads/WebPlotDigitizer-4.1-linux-x64.zip
+ source = webplotdigitizer.desktop
md5sums = 6d6b74f94f5922cfe9b24a1dbe035edd
+ md5sums = bbb5539842f94b8e986ba31c5f564003
sha256sums = 7cfffa19d160c07df71121fe005fdcdb1fdd48dd3e70fb391dcbe5ca529bafd8
+ sha256sums = 30ddc4aef0b82c9b22dc9aeb9dbacd7cf3dd60cd1805cdc9db01da3db9a1ceef
pkgname = webplotdigitizer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2d91b0b30412..b2ceb100e14d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Excitable Snowball <excitablesnowball@gmail.com>
+_name=WebPlotDigitizer
pkgname=webplotdigitizer-bin
pkgver=4.1
pkgrel=1
@@ -7,13 +8,22 @@ pkgdesc='Tool to extract numerical data from plot images'
url='https://automeris.io/WebPlotDigitizer/'
arch=('x86_64')
license=('AGPL3')
-depends=()
-source=('https://automeris.io/downloads/WebPlotDigitizer-4.1-linux-x64.zip')
-md5sums=('6d6b74f94f5922cfe9b24a1dbe035edd')
-sha256sums=('7cfffa19d160c07df71121fe005fdcdb1fdd48dd3e70fb391dcbe5ca529bafd8')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
+source=("https://automeris.io/downloads/${_name}-$pkgver-linux-x64.zip"
+ "${pkgname%%-bin}.desktop")
+md5sums=('6d6b74f94f5922cfe9b24a1dbe035edd'
+ 'bbb5539842f94b8e986ba31c5f564003')
+sha256sums=('7cfffa19d160c07df71121fe005fdcdb1fdd48dd3e70fb391dcbe5ca529bafd8'
+ '30ddc4aef0b82c9b22dc9aeb9dbacd7cf3dd60cd1805cdc9db01da3db9a1ceef')
package() {
- mkdir -p "$pkgdir/opt" "$pkgdir/usr/bin"
- cp -r WebPlotDigitizer-linux-x64 "$pkgdir/opt/WebPlotDigitizer"
- ln -s /opt/WebPlotDigitizer/WebPlotDigitizer "$pkgdir/usr/bin/WebPlotDigitizer"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/opt"
+
+ cd "$srcdir"
+ cp -r "${_name}-linux-x64" "$pkgdir/opt/${pkgname%%-bin}"
+ ln -s "/opt/${pkgname%%-bin}/${_name}" "$pkgdir/usr/bin/${pkgname%%-bin}"
+
+ install -Dm644 "$pkgdir/opt/${pkgname%%-bin}/resources/app/images/icon/icon.svg" "$pkgdir/usr/share/pixmaps/${pkgname%%-bin}.svg"
+ install -Dm644 "${pkgname%%-bin}.desktop" "$pkgdir/usr/share/applications/${pkgname%%-bin}.desktop"
}
diff --git a/webplotdigitizer.desktop b/webplotdigitizer.desktop
new file mode 100644
index 000000000000..5b4e62714815
--- /dev/null
+++ b/webplotdigitizer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=WebPlotDigitizer
+Comment=Web based tool to extract data from plots, images, and maps
+GenericName=Web Plot Digitizer
+Exec=webplotdigitizer %U
+Icon=webplotdigitizer
+Type=Application
+StartupNotify=true
+Categories=Education;
+StartupWMClass=webplotdigitizer
+X-Desktop-File-Install-Version=0.24