aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Cho2023-10-03 22:17:02 +0900
committerXavier Cho2023-10-03 22:17:02 +0900
commit0255555a99f0b41d0be0f55da6e7efac740e1a2c (patch)
tree574671608e693b6285e150ca718953fdbfd70430
parent5c73600df6a0f3dad5c91d445be217bccaa9a47b (diff)
downloadaur-0255555a99f0b41d0be0f55da6e7efac740e1a2c.tar.gz
Fix USD patch problem due to CMakeList update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--usd.patch24
3 files changed, 9 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8aa71a056df..1e440be21497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upbge-git
pkgdesc = Uchronia Project Blender Game Engine fork of Blender Game Engine
- pkgver = 133373.00f0df37d6f
+ pkgver = 134573.ec6556fa36e
pkgrel = 1
url = https://upbge.org/
install = upbge.install
@@ -73,7 +73,7 @@ pkgbase = upbge-git
sha256sums = SKIP
sha256sums = b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a
sha256sums = ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff
- sha256sums = 344259c0cb968f12a9aba1a995dc40f386bab2f65e118c9c2e46c192c6b65c84
+ sha256sums = e7b30006871799b104dfc51ec98af2528e387623f8eb5e24912beae726d517c7
sha256sums = 155c04f971d3f45618a89fa73d91e21ba493ae24029475e18192c49c3fcd8cb4
sha256sums = a35710a189324679322e74b65754993831fe0ac7db3f9a774a1b799afba6cd08
diff --git a/PKGBUILD b/PKGBUILD
index e633d8374fde..b13eeb8aaa3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#shellcheck disable=SC2015
pkgname=upbge-git
-pkgver=133373.00f0df37d6f
+pkgver=134573.ec6556fa36e
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=("i686" "x86_64")
@@ -54,7 +54,7 @@ sha256sums=(
"SKIP"
"b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a"
"ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff"
- "344259c0cb968f12a9aba1a995dc40f386bab2f65e118c9c2e46c192c6b65c84"
+ "e7b30006871799b104dfc51ec98af2528e387623f8eb5e24912beae726d517c7"
"155c04f971d3f45618a89fa73d91e21ba493ae24029475e18192c49c3fcd8cb4"
"a35710a189324679322e74b65754993831fe0ac7db3f9a774a1b799afba6cd08")
diff --git a/usd.patch b/usd.patch
index bc14274d1fa8..cbd81a66e909 100644
--- a/usd.patch
+++ b/usd.patch
@@ -1,22 +1,8 @@
-diff --git a/build_files/cmake/Modules/FindUSD.cmake b/build_files/cmake/Modules/FindUSD.cmake
-index f3b7d88a073..e77c0651e71 100644
---- a/build_files/cmake/Modules/FindUSD.cmake
-+++ b/build_files/cmake/Modules/FindUSD.cmake
-@@ -46,7 +46,7 @@ endif()
- # See https://github.com/PixarAnimationStudios/USD/blob/release/CHANGELOG.md#2111---2021-11-01
- find_library(USD_LIBRARY
- NAMES
-- usd_usd_m usd_usd_ms usd_m usd_ms
-+ usd_usd
- ${PXR_LIB_PREFIX}usd
- NAMES_PER_DIR
- HINTS
-
diff --git a/source/blender/io/usd/CMakeLists.txt b/source/blender/io/usd/CMakeLists.txt
-index 568ed4c7641..c847adbd077 100644
+index fa20dc94941..26d9f43ee1b 100644
--- a/source/blender/io/usd/CMakeLists.txt
+++ b/source/blender/io/usd/CMakeLists.txt
-@@ -62,6 +62,7 @@ set(INC
+@@ -77,6 +77,7 @@ set(INC
set(INC_SYS
${USD_INCLUDE_DIRS}
${BOOST_INCLUDE_DIR}
@@ -24,7 +10,7 @@ index 568ed4c7641..c847adbd077 100644
${TBB_INCLUDE_DIR}
${PYTHON_INCLUDE_DIR}
)
-@@ -149,6 +150,10 @@ if(WITH_OPENVDB)
+@@ -208,6 +209,10 @@ if(WITH_OPENVDB)
${OPENVDB_LIBRARIES}
)
endif()
@@ -33,5 +19,5 @@ index 568ed4c7641..c847adbd077 100644
+ list(APPEND __boost_packages python)
+endif()
- blender_add_lib(bf_usd "${SRC}" "${INC}" "${INC_SYS}" "${LIB}")
-
+ if(WITH_MATERIALX)
+ add_definitions(-DWITH_MATERIALX)