summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-05-02 19:25:36 +0900
committerhayao2021-05-02 19:25:36 +0900
commit0268927eb23422652bd3fa403405c49c8770dc29 (patch)
tree6c311b01aab96b9534609324c1e6c3e49d29567e
downloadaur-0268927eb23422652bd3fa403405c49c8770dc29.tar.gz
[add] : Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..234cf5a4dd2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = grub-theme-zorin-bin
+ pkgdesc = GRand Unified Bootloader, version 2 (Zorin theme)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://zorinos.com/
+ arch = any
+ license = GPL
+ depends = grub
+ conflicts = grub-theme-zorin
+ conflicts = grub-theme-zorin-git
+ source = https://launchpad.net/~zorinos/+archive/ubuntu/stable/+files/grub-theme-zorin_1.2.1_all.deb
+ md5sums = SKIP
+
+pkgname = grub-theme-zorin-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eab55cd7b1f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+pkg
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aee680f15216
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Yamada Hayao <development@fascode.net>
+
+_pkgname="grub-theme-zorin"
+pkgname="${_pkgname}-bin"
+pkgdesc="GRand Unified Bootloader, version 2 (Zorin theme)"
+
+deb_pkgver="1.2.1"
+pkgver="${deb_pkgver}"
+pkgrel="1"
+
+arch=('any')
+url="https://zorinos.com/"
+license=('GPL')
+conflicts=("${_pkgname}" "${_pkgname}-git")
+
+depends=("grub")
+optdepends=()
+
+source=("https://launchpad.net/~zorinos/+archive/ubuntu/stable/+files/${_pkgname}_${deb_pkgver}_all.deb")
+md5sums=('SKIP')
+
+prepare(){
+ while read -r pkg; do
+ dir="$(echo "${pkg}" | cut -d "." -f 1)"
+ mkdir -p "${dir}"
+ tar -x -v -f "${pkg}" -C "${dir}"
+ done < <(find "${srcdir}" -maxdepth 1 -mindepth 1 -name "*.tar*" -printf "%p\n")
+}
+
+package() {
+ cp -ar "${srcdir}/data/"* "${pkgdir}"
+}